Highlighted
Justin Yaple
1 Copper

Optiplex 160 BIOS wont update (because the fan is missing?)

Jump to solution

Hello,

I just got a used Optiplex 160 (Model DC01T) with BIOS A06 and have tried everything to get it to update to BIOS A10, A09, A08 or A07.

I downloaded the unified DOS/Windows BIOS and put it on a FreeDOS USB stick.  When I run the package it goes through everything and then reboots but never actually updates the BIOS.  I have tried installing Linux on a USB Flash drive installing the Dell OMSA tools and use dellBiosUpdate pointing to the A09.HDR file.

For whatever reason that also fails because the dell_rbu module does not populate "/sys/class/firmware/dell_rbu/" like it should.  Also no amount of copying "init" to  "/sys/devices/platform/dell_rbu/image_type" helps correct that issue.

The only thing I can think of is that when the system reboots it goes to an "Alert Fan!" message because this unit did not come with the HD & Fan bracket.  I have one on its way but if that Alert/Error is clearing the BIOS update flag then everything should work once the fan arrives and I get that connected.

If that's not the case is there anything else I should try?

3 Replies
Justin Yaple
1 Copper

RE: Optiplex 160 BIOS wont update (because the fan is missing?)

Jump to solution

I finally got it  figured out if anyone is interested.  The fan error might be causing the normal update to fail but using a bunch of switches you can force the update to install and then reboot.

O160-A10.EXE /boot /classic /info /jabil /nopause /noreboot /verbose

yaser_man
1 Copper

RE: Optiplex 160 BIOS wont update (because the fan is missing?)

Jump to solution

thx for new adress

0 Kudos
yaser_man
1 Copper

RE: Optiplex 160 BIOS wont update (because the fan is missing?)

Jump to solution

oh  goooooooood man

0 Kudos