Highlighted
Fozzie Bear
Phosphor

Optiplex 3040 - Numlock does not stay on after boot

Jump to solution

I have just configured an Optiplex 3040 for a customer to run Virtual XP machines for his CNC mills.

I upgraded from windows 7 Professional to Windows 10 64 Bit Pro as the replacement CAD/CAM software he is trialling needs this 64 bit OS.

Apart from a lot of research to find out why I couldn't boot from the Windows 10 DVD media to install Windows 10 (not included in the Dell FAQs) everything runs OK. However there is one niggle in that on boot the Numlock doesn't stay on.

I have checked the bios and the relevant setting in the Post section is ticked and the Numlock LED comes on during Post but then goes off as Windows 10 loads. This is not a big problem but rather annoying as the customer uses the numeric keyboard a lot for data entry of measurements.

Is this a bug in the Dell Bios or is it something to do with UEFI?

Many thanks 

Fozzie

0 Kudos
4 Replies
Thorium

RE: Optiplex 3040 - Numlock does not stay on after boot

Jump to solution

On some Inspiron models, disabling Fast Startup from inside Windows 10 fixes that problems. So you might try that....

1.Type Control Panel in the search box.

2.Click Control Panel.

3.Click Power Options.

4.Click Choose what the power buttons do.

5.Click Change settings that are currently unavailable.

6.Scroll down to Shutdown settings and uncheck Turn on fast startup.

7.Click Save changes.

8. Reboot

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Fozzie Bear
Phosphor

RE: Optiplex 3040 - Numlock does not stay on after boot

Jump to solution

Many thanks Ron,

After several internet searches this appears to be a Windows 10 UEFI issue. I will certain get the customer to try your suggestion although I think I may have found an alternative solution as below.

"Boot the computer to log in screen. When you reach the login screen, press the Num Lock key once to enable it. Don’t log into the computer. From the login screen, click the power button and select “Shut down” to shut down the computer again.

Boot the computer back up and Num Lock will be enabled on the login screen. It seems that this puts Fast Startup into a state where it will automatically enable Num Lock at every boot. Yes, this is a weird trick–but it works. (Thanks to DznyRulz on Reddit for discovering this!)"

Saltgrass
Ruthenium

RE: Optiplex 3040 - Numlock does not stay on after boot

Jump to solution

I was able to find a site which showed how to alter the Registry to allow the Num Lock to stay engaged.

I am thinking disabling the Num Lock is being done on purpose due to the touchscreen keyboards.  I don't know for sure, but if the Num lock was enabled, what keyboard would pop up at logon, the letters or numbers version..

I need to check what type of keyboard comes up at logon but I think it might be the full version... after you are in Win 10 you can select what version of the keyboard comes up, but tablets and phones may be different.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Thorium

RE: Optiplex 3040 - Numlock does not stay on after boot

Jump to solution

"Boot the computer to log in screen. When you reach the login screen, press the Num Lock key once to enable it. Don’t log into the computer. From the login screen, click the power button and select “Shut down” to shut down the computer again.

Boot the computer back up and Num Lock will be enabled on the login screen. It seems that this puts Fast Startup into a state where it will automatically enable Num Lock at every boot. Yes, this is a weird trick–but it works. (Thanks to DznyRulz on Reddit for discovering this!)"

That's probably just a different way to disable Fast Startup than what I posted... 

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos