Highlighted
Jeibie62
Copper

Optiplex 7040 - Boot problems when using Displyport only

Hi there,

I'm getting a "no boot devices found" error if I' connect my monitor via a Displayport cable instead of HDMI cable.

Is there a solution for this?

Thanks
Juergen 

0 Kudos
14 Replies
Thorium

RE: Optiplex 7040 - Boot problems when using Displyport only

What version of BIOS?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Jeibie62
Copper

RE: Optiplex 7040 - Boot problems when using Displyport only

1.1.1

0 Kudos
Thorium

RE: Optiplex 7040 - Boot problems when using Displyport only

That appears to be the latest.

I'll ping my Dell tech contacts...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Thorium

RE: Optiplex 7040 - Boot problems when using Displyport only

BTW:

What form factor 7040?

Are you connecting to onboard video outputs or to add-in video card? If you have an add-in video card, the first monitor probably has to be connected to the card.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Moderator
Moderator

RE: Optiplex 7040 - Boot problems when using Displyport only

A monitor should never be interpreted by the operating system as a boot device? Are you connecting a single monitor or dual monitors? What specific monitor model? Which chassis?

0 Kudos
Jeibie62
Copper

RE: Optiplex 7040 - Boot problems when using Displyport only

Dear all,

its a Optiplex Mini-Tower that has only onboard Intel graphic (1x HDMI, 2x DP) connected to a Dell U3415W.

But I cant't use HDMI because the monitor provides one HDMI connector which is used by another PC.

I suppose its a problem with BIOS and PCI interrupts that are twice taken if you connect DP only.

0 Kudos
Thorium

RE: Optiplex 7040 - Boot problems when using Displyport only

Do you get the error when the monitor is connected to the 7040 via DP but the monitor is not connected to the HDMI cable?

In other words, is the 7040 detecting the other PC's video card through the HDMI connection, even if the other PC is off?

You may need a KVM switch which allows you to share monitor, keyboard and mouse between two PCs...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Moderator
Moderator

RE: Optiplex 7040 - Boot problems when using Displyport only

* Turn the U3415W, Optiplex, and the other computer off
* Disconnect the HDMI cable from the U3415W
* Connect only the DP (DisplayPort) from the Optiplex to the U3415W
* Turn the U3415W on, then the Optiplex

0 Kudos
Jeibie62
Copper

RE: Optiplex 7040 - Boot problems when using Displyport only

I did that and sometimes it seems to work.

But after a complete powercyle it seems fo fail. The only workaround to made it to work again, is to connect Optiplex via HDMI to the monitor.

As this is in a business environent its a no go solution.

0 Kudos