jepoor
1 Copper

Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

Optiplex 9010 AIO built-in Webcam not working properly.
Windows 10 installed Microsoft driver as Integrated Webcam.
Worked properly in Skype for Business 2016.
After Windows 10 Anniversary Update, stopped working.
Uninstalled device in Device Manager; rebooted and allowed Windows to detect.
Installed as USB Video Device.
Works intermittently
Have to keep uninstalling device and re-detecting.
Works for a day and then stops again.
Uninstalling and detecting flips between Integrated Webcam and USB Video Device.
All current windows 10 updates installed.
Verified apps are "allowed" to access webcam.

Internet search reveals this is a VERY common problem and there does not appear to be any resolution from Microsoft.

When Webcam stops working it does not work in Skype for Business 2016, Windows Camera app; Web-based diagnostic site.
Audio works.
Incoming video and audio work.
No alerts show in Device Manager
Attempt to update driver from Internet shows best driver installed.
Attempt to install driver by pointing to Dell Windows 10 driver cab file shows best driver installed.

CONFIGURATION:
Windows 10
    Version 1607
    OS Build 14393.447
    64-bit

Dell Optiplex 9010 AIO (certified by Dell)
    Latest BIOS version
    Current drivers as detected by Dell System Detect

Current USB Video Device settings:
    General-Device is working properly
    Driver-Microsoft; Driver date of 6/21/2006; Driver version as 10.0.14393.82; Driver signer as Microsoft Windows

1. I have run SFC /SCANNOW with no errors

2. I have run DISM with both repair options with no errors.

3. I have run Hardware Troubleshooter

4. I have uninstalled/reinstalled Office 2016 with no change to Skype for Business 2016

5. Disabling fast startup was suggested with no change.

No answers from Microsoft as may be expected!

0 Kudos
6 Replies
Moderator
Moderator

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

jepoor,

Click the link below, scroll to the bottom of the page to follow the steps shown for fixing the webcam.

Fix Webcam Issues After Windows 10 Anniversary Update

Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Would you like to be a Dell Community Rockstar?
0 Kudos
7 Plutonium

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

USE Notepad to copy the text below and save as FIXWEBCAM.TXT

Save the text on the desktop

Then rename to FIXWEBCAM.REG

Then Double click on it to import into Registry

Then reboot.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform]

"EnableFrameServerMode"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows Media Foundation\Platform]

"EnableFrameServerMode"=dword:00000000


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
jepoor
1 Copper

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

I had already done the 2 registry entries.

Rollback is not an option.

I will not use a 3rd party utility.

0 Kudos
Moderator
Moderator

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

jepoor,

Roll back to original build of W10 to see if that will work. If so, you can try the update again and check the Webcam.

Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Would you like to be a Dell Community Rockstar?
0 Kudos
jepoor
1 Copper

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

Well...per the previous reply I am unable to do so...

0 Kudos
cab driver
1 Copper

RE: Optiplex 9010 AIO Webcam, not working with Windows 10 Anniversary update

same problem

0 Kudos