Highlighted
lrios103
1 Copper

Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

After updating to A18 on several machines I have noticed that they all hang after DHCP address is assigned and what would normally be the menu count down (if there wasn't any jobs pending) or the launch of the automation boot. 

I also noticed this when updating to latest version on our Latitude E6420s as well.  Reverting to A17 on the 990 and the 6420 fixed this problem.

Is anyone else having this issue, and has this been reported to Dell.  I attempted to Google this however no matter how i worded the search I didn't find anything with recent BIOS.

0 Kudos
1 Solution

Accepted Solutions
8 Krypton

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

Hello Irios103,

Its difficult to determine what is causing the conflict with Bios version A18 and your systems. The improvements to code could be causing issues on the Cisco switches or an older feature, such as the spanning tree or the power conserving feature.  You may also want to ensure that port fast is enabled.
If you don't need any of the specific fixes in this version of the Bios, it may be best not to use it.

The Fixes & Enhancements for the version shows:
1. Addressed system does not respond to keyboard intermittently.
2. Addressed UEFI OS fail boot with HDD password present issue.
3. Addressed CCTK issues.
4. Improve the compatibility of PCI devices and USB devices.
5. Update Intel Microcode for SandyBridge processor.
6. Update Intel PXE ROM.

I hope this helps.  Please let us know if you require further assistance or more information.
~Maureen
#iwork4dell

DELL-Maureen F

Get Support on Twitter @DellCaresPro
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
6 Replies
8 Krypton

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

I pinged my Dell contacts for you.

The A18 BIOS update included an update to the Intel PXE ROM, so there could be an issue with how the PXE got updated...

Given the holidays, it may take until next week before somebody from Dell has a chance to look at this...

 

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
8 Krypton

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

Hello Irios103,

Its difficult to determine what is causing the conflict with Bios version A18 and your systems. The improvements to code could be causing issues on the Cisco switches or an older feature, such as the spanning tree or the power conserving feature.  You may also want to ensure that port fast is enabled.
If you don't need any of the specific fixes in this version of the Bios, it may be best not to use it.

The Fixes & Enhancements for the version shows:
1. Addressed system does not respond to keyboard intermittently.
2. Addressed UEFI OS fail boot with HDD password present issue.
3. Addressed CCTK issues.
4. Improve the compatibility of PCI devices and USB devices.
5. Update Intel Microcode for SandyBridge processor.
6. Update Intel PXE ROM.

I hope this helps.  Please let us know if you require further assistance or more information.
~Maureen
#iwork4dell

DELL-Maureen F

Get Support on Twitter @DellCaresPro
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
8 Krypton

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

Thanks Maureen!

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
StephenJabs
1 Copper

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

I am experiencing the exact same issue.  A18 on the OptiPlex 990 causes it to fail on PXE boot.  The release notes on A18 state it updates the Intel PXE ROM  (obviously not for the better), so I will be reverting to A17 for now.

According to the boot screens:

Dell BIOS A17 uses Intel Boot Agent GE 1.3.81 with PXE Base Code 2.1 build 089.

Dell BIOS A18 uses Intel Boot Agent GE 1.5.33 with PXE Base Code 2.1 build 092.

0 Kudos
EsherCollege
1 Copper

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

We are experiencing the exact same problem with our Optiplex 790's. We need this BIOS update as we need the keyboard fix.

PXE booting seems to work fine when the computer is on the same VLAN as the WDS server, but not a different one. Reverting back to A17 solves the problem so there is clearly some sort of issue with the PXE firmware in A18.

 I know this is an old thread for an old machine so I doubt Dell will do anything about the issue, but we have over 200 790's and aren't getting rid of them any time soon!

0 Kudos
jdmun
1 Copper

RE: Optiplex 990 Won't PXE boot after A18 Bios Update

Jump to solution

I have the same problem with A18 not booting with PXE on OptiPlex 990.  Just tried upgrading to A19 hoping it would fix the problem but PXE Boot still did not function on a public network address range.  A18 would PXE boot on a private network address range, but not on a public network address range. Strange. Did not try A19 on Private address range, but not what I wanted. So reverted back to A17 that presently works no mater what the IP Address range.