Highlighted
divenal
1 Copper

Optiplex GX280 - intermittent POST ram problem

Hi,

    my GX280 beeps just after switch-on. At first, it was intermittent - opening the case or moving the box was sufficient, but it's been getting worse, and now it won't go beyond this POST failure.  I'm not sure if it's just a coincidence, but monitor seems to have broken at the same time. Not sure if one caused the other, or what happened.  There was a lot of dust inside to clean out !  Haven't yet investigated monitor state, since I had a spare.

No config has changed recently (hardware or software), other than the monitor.

Yesterday after a successful boot, I run the x86 memory tests (I happened to have it installed as a boot option in grub menu). No problems reported.

Anyway, having now started to analyse properly,  the beep pattern is 1-3-2 which I think indicates a ram problem. It has 2 x 1Gb modules (upgraded a few years ago).

Tried reseating. Tried removing, swapping round, etc. It did once boot up with one module installed, but then stopped again after I swapped things around some more. Even going back to the working config didn't work second time.

Having finally searching online to find out more, I see I can use the diagnostic LEDs on the back. They are currently showing green-yellow-green-yellow, which is bad memory config.  Removing both ram modules all gave me G-Y-Y-Y which is no memory. So that's good. Putting one in seemed to pass the POST (no monitor attached, but gave the double-beep indicating it was happy).  Powered off, added the second module, and got G-Y-G-Y. Took it out, and it's still G-Y-G-Y.

A new (intermittent) failure mode has appeared : fan going into high-speed with no sign of activity on the POST lights. Fiddling with connectors and cables seems to help.

Suggestions ? Does memory typically fail in such an intermittent way ?  Is motherboard dying ? Power supply ?

0 Kudos