Highlighted
ghostdoc
1 Copper

Please help: Dell Inspiron Desktop 531 fail to boot after RAM upgrade

A week ago, I have an aging Inspiron Desktop 531 which I decided to upgrade. I installed Windows 7 home 32-bit and added a GT240 1 GB video card and system was able to easily recognize new card and PC was running stable.

Last night, I decided to add 2 sticks of 1GB Kingston PC2-5300 CL5 RAM and system would not boot but gave 2 beeps. Before purchasing, I researched and these Kingston RAM have same timings and voltage as OEM ones.

I checked the slots and RAM were seated correctly. I removed ALL the RAM sticks and inserted only the OEM RAM (previously in the 1-2 position) and transferred to  the 3-4 slots and the system booted with no problem. So now I can confirm that slots 3-4 are working. I removed the OEM RAM and inserted the Kingston RAM in the 1-2 position and the system booted fine. I removed Kingston RAM from 1-2 slots and transferred to the 3-4 slots  and the system booted again. BUT when I insert ALL four sticks the system failed to boot and gave 2 continuous beeps.

Btw, I even tried to insert the 2 OEM and just 1 Kingston and still got same result.

I realized I still have a stock PSU but I doubt the GT240 and 2 additional RAM will cause system to fail.

Thanks in advance for all the kind help.

0 Kudos
1 Reply
7- Thorium

Re: Please help: Dell Inspiron Desktop 531 fail to boot after RAM upgrade

Hi ghostdoc,

I'm not sure what to say. I think you've pretty much proven what happens when you mix the OEM and Kingston RAM. This is not a power supply problem, as RAM by itself does not draw significant power.

We generally recommend Crucial, which comes with a compatibility guarantee. Kingston does work in many systems but has mixed results in others.

0 Kudos