Highlighted
rootingbill
1 Copper

Problem using PXE Boot for Optiplex 9020

Hi there,

I'm having some problems using PXE boot with a Windows DHCP Server (tried Server 2003 R2 and Server 2008 R2). The DHCP Server never seems to get a DHCP DISCOVERY. After many hours and days of testing i found a (temporary) solution for myself:

The machines were delivered with the BIOS Revision A03 and A04 (we got 91 machines). After reviewing the bios history i noticed that there was a update of the PXE ROM, coming along with A03. So i downgraded to A02  and PXE boot worked perfectly!

Did someone else made this experience?


Greetings,

Patrick

4 Replies
Murisonc
1 Nickel

RE: Problem using PXE Boot for Optiplex 9020

I'm glad I found this.  We have been stumped.  We tried to upgrade the BIOS to A07 but that didn't work.  Downgrading to A02 fixed the problem.

Dell, can you please fix this in the next version.

Chuck

jselix
1 Nickel

RE: Problem using PXE Boot for Optiplex 9020

same issues here. we have WDS on Server 2012 R2 and a Dell on A07 bios; never finds the download file however i downgrade to A02, zero issues.  Upgrade to A12 for the Dell 9020; same issues.  PXE Error E53, File not found.  

Support of course says they don't deal w/PXE issues even though they caused the issues it seems. then who does?

0 Kudos
7- Thorium

RE: Problem using PXE Boot for Optiplex 9020

Are these the 9020 or the 9020 All-in-One?

9020 is up to BIOS A13 and A09 "Fixed the PXE boot option appears on boot sequence improperly" (huh??).  A03 "Updated Intel PXE ROM to 1.5.38", so that could have caused the problem you're having and why A02 works.

9020 AIO is up to BIOS A11 and A08 "Fixed Can not get a reserved IP address for PXE boot."

You only need to update directly to the latest version since fixes/enhancements are supposed to be  cumulative. Don't know if the latest BIOS will solve your PXE problems, but you can always revert. Keep in mind that there's always a (small) chance a BIOS update will fail and brick the motherboard, so that's something to consider...

If you update to latest version and still have the PXE problem, I can ping my Dell tech contacts for help. Post back either way and let us know what happens...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
joe.souza
1 Copper

RE: Problem using PXE Boot for Optiplex 9020

A02 Fixes the problem however who knows WHAT WILL QUIT WORKING NEXT this is unacceptable not putting emphasis on this issue?? many enterprise users require PXE to work for MDT SCCM Etc We DO count with this feature working. Now if you have 100 systems you'd have to downgrade the BIOS to A02 I guess mine came with A12 Upgraded too A13 nope did not work, tried from that point on Backwards until A02 which did worked.  

0 Kudos