robbieuk
2 Bronze

QX6800 dell xps 420 bios not registering full title

I have installed a QX6800 cpu in my dell xps 420. the bios revision I have is A06 which is the latest for the motherboard, my dilemma is that in the bios it does not state qx6800 2.93GHZ but just core 2 quad (then a blank space where it should state QX6800) and the 2.93GHZ, as I had a Q6600 running and that was stated with its full title inc Q6600, also in windows welcome centre vista and device manager it just states quad core and 2.93ghz no sign of the QX6800 but there is a blank space as to where it sould state QX6800, please help as to what I can do so it states QX6800, in CPU Z it is recognised as the QX6800 so why not in the bios, I have a corsair HX520 PSU and also running a 8800 ultra which is recognised using its full title.
Message Edited by robbieuk on 09-26-2008 09:31 AM
0 Kudos
4 Replies
vvspy
2 Iron

Re: QX6800 dell xps 420 bios not registering full title

i won't worry this if the CPU delivers full power.
0 Kudos
robbieuk
2 Bronze

Re: QX6800 dell xps 420 bios not registering full title

for an expensive cpu it should show the full name of the cpu, yet it does not. this is rather annoying, also the bios is the latest A06 for the xps 420, the quad q6600 was showing in full but nothe quad extreme qx6800, as people want to see that you have the quad extreme cpu, it learly shows it in cpu z the full name so why not in the bios, and this reflects in windows vista as it comes as intel core 2 quad and then a space and @ 2.93GHz, this is not, please help
0 Kudos
Davet50
2 Iron

Re: QX6800 dell xps 420 bios not registering full title

This is a bios issue and not the Chip. This has also occured on the 700/710/720 systems as well. It has nothing to do with the chip.

I agree when they write the bios's you would think they would write them to report the chips correctly.

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

0 Kudos
robbieuk
2 Bronze

Re: QX6800 dell xps 420 bios not registering full title

Hi I agree it is a bios issue as what is stated in the bios is also stated word by word in windows, which is unfair as it looks like an overclocked cpu and is not addressed in full, it there an update for this as it is really unfair since these extreme cpus are not cheap and if I had known this then I would have not bought such an expensive chip, as you spend money and u would like others to appreciate that when they see the system, pease help for any updates as it is upsetting me every time I look at the windows screen and bios
0 Kudos