davidvf
1 Copper

Screens go blank on fresh copy of XP on 670 Precision

Hello, I replaced the hard drive on a Dell Precision 670 that has a Matrox QID LP PCIe video card and am unable to get all screens working with a fresh copy of XP. It will load in safe mode and with a generic driver on one screen but when the Matrox driver is loaded, all 4 connected Dell screens go blank after the XP logo during bootup. Matrox have used the same card in a Dell 670 to try and simulate the problem but they can't. They have remotely connected to the system and can't find anything wrong. In fact, they can see the screens and use the system remotely. They can direct me to use the keyboard, for example, to login and all that works except my screens are blank. I've tried various drivers that install correctly and appear OK in the device manager. Also, I have an old image that I can load where all screens work but that copy of XP has a problem that causes a blue screen crash that I can't repair. I've run out of things to try - would appreciate any help/ideas. Thanks, David

0 Kudos
3 Replies
7- Thorium

Re: Screens go blank on fresh copy of XP on 670 Precision

When you did the new install, did you install the Intel motherboard chipset drivers?  We find that is an often skipped item and it is key to a successful install. 

In the install the chipset drivers are installed BEFORE installing device drivers. 

If you didn't install them, that COULD be an issue. 



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS ROG Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives. Cakewalk by BandLab and Studio One 4.1 Recordng Studio Software.

Dell S2719dgf Monitor

Member of Nashville based R.O.P.E.

0 Kudos
davidvf
1 Copper

Re: Screens go blank on fresh copy of XP on 670 Precision

Thanks. I didn't install the motherboard chipset drivers before the fresh XP install. I'll do this and reinstall the video driver and report back.

0 Kudos
Highlighted
davidvf
1 Copper

Re: Screens go blank on fresh copy of XP on 670 Precision

Unfortunately, updating the chipset drivers didn't solve the problem. Matrox ran the same QID graphics card on a Dell 670 Precision running Windows 7 so I know it can be done and have eliminated the chipset and driver. I'd appreciate any other things that I could look at. Thanks

0 Kudos