Not applicable

Solid orange power button on Optiplex GX520

Hi all,

I recently acquired an Optiplex GX520 desktop but when you plug the power lead in the power button stays orange and the CPU fan spins up for a second but nothing else happens. The orange LED on the motherboard is on, I tried unplugging all peripherals from the power (CD ROM, HDD, FDD etc.) and removed the one stick of DDR2 and still the same. Tried suggestions online of holding the power button in whilst it was turned off etc.

I noticed the SATA HDD didn't start up yet when I checked the connectors with a multimeter it was just under 12v so it looks like power is going to them. Yet I tested the HDD and it works fine, just doesn't spin up in this machine. Also no diagnostic lights and no output to the monitor at all.

I checked all the USB ports for shorting as well, I also tried reseating the CPU.

I fear it could be the PSU or the motherboard, if the only thing getting power was the motherboard (no RAM or cards etc or anything else plugged in) would it be expected to boot to green power LED?

I want to avoid buying a PSU if it's the motherboard at fault so any help or advice would be much appreciated.

0 Kudos
2 Replies
Highlighted
3 Cadmium

RE: Solid orange power button on Optiplex GX520

A solid amber power button indicates a motherboard failure. You will need to get the motherboard replaced.

-Brandon


Forum Member Since 2010
I, like others, am a forum member and not an employee of Dell

0 Kudos
Highlighted
Not applicable

RE: Solid orange power button on Optiplex GX520

Thanks balong, I'll give that a try and see how things go.

0 Kudos