ehalldim3000
1 Copper

Sound problems with DIM3000

I have a Dell Dimension 3000 with an integrated ADI SoundMAX card and I have only limited sound capabilities.  I have NO Windows sounds being played even though the default scheme is enabled.  If I attempt to launch a video from the internet (MSN, You Tube, etc.) the video plays but there is no sound.  I can play CDs or stored music without any problem using Rhapsody.  No sure what has caused this problem to crop up. 

 

I have run Dell Diagnostics (Driver Reset) and no errors were discovered.  I ran DXDIAG and both sound and music tests and plays fine.  I have used the Dell Support Center to download the latest version of the audio driver for SoundMAX.  I also did an online automated scan (PC checkup) which found no problems.  I have checked and re-checked all settings in Control Panel => Sounds and Audio Devices.  Everything is enabled for use.  I have gone through the entire Windows XP troubleshooter and everything looks OK.  However, there is 1 anomaly worth pointing out: The volume control ICON will not appear on the Windows taskbar even though the menu item to display it is checked in the SoundMAX properties   The only thing I have not done is to upgrade the BIOS to A03.  I have no idea what has caused this problem.  Any assistance would be greatly appreciated.

0 Kudos
5 Replies
Alexandra_P
4 Germanium

Re: Sound problems with DIM3000

It sounds like a software or registry glitch somewhere in XP.   If it's possible to go back far enough, system restore is usually the easiest way to try and recover it. 

 

One possibility:  Start, Run, type services.msc in the run box.  In the services list make sure Windows Audio Service is both started and automatic.

 

The volume control is handled by C:\Windows\System32\sndvol32.exe.  If it's damaged somehow that might explain the volume icon problem.  You might have a backup copy in your C:\i386 folder which you can use to replace the one in system32 (make sure to show all hidden files first), but if not you'd need to extract it from the CD.

 

http://support.microsoft.com/kb/319095


'Tis a poor carpenter that blames his tools.

0 Kudos
ehalldim3000
1 Copper

Re: Sound problems with DIM3000

Thanks for the suggestions.  I had already verified that Windows Audio service was active and had also re-installed sndvol.  I am trying to avoid going back thru restore points.  I was suspicious of Rhapsody and Media player.  I did an upgrade to Media Player 11 and uninstalled Rap -- same results.
0 Kudos
Highlighted
Alexandra_P
4 Germanium

Re: Sound problems with DIM3000

Hmm...  Try replacing the msacm32.drv file.

 

http://www.techsupportforum.com/microsoft-support/windows-xp-support/212202-no-system-sounds-volume-... 

 

No reason to fear system restore.  You won't lose any data, only any programs or updates you've installed since the restore point was created, and it can be undone if necessary.   If nothing else it may help confirm what software or update was the culprit.

 


'Tis a poor carpenter that blames his tools.

0 Kudos
ehalldim3000
1 Copper

Re: Sound problems with DIM3000

This was a good suggestion but still no sound.  My msacm32.drv looked fine -- but I did an expansion from the Windows CD and replaced it anyway...no luck.  I'm wondering if the problem is the msacm32.dll -- can't expand/replace it because it is in use.  This is like shooting fish in a barrel...
0 Kudos
Alexandra_P
4 Germanium

Re: Sound problems with DIM3000

I think the phrase your looking for is "needle in a haystack". 

 

You can check all the windows files in one go with system file checker.

 

Start - run, type sfc /scannow

It will ask for the XP CD if it needs it.

 

Only problem you might run into is if the version of XP on your CD is SP1 or SP2, and you have a later version (e.g., your CD is SP2 but you've already installed SP3).

 

My guess is this is more likely to be a registry problem, though.  I've collected a fair pile of links, but don't know if you want to go that far.  System restore is safer.

Message Edited by Alexandra_P on 08-18-2008 05:25 PM


'Tis a poor carpenter that blames his tools.

0 Kudos