Moderator
Moderator

Re: Studio XPS 9000/435T - Can't disable onboard lan!?

Hi again,

Thanks for sending me your service tag, it's very much appreciated.

I see from the system details that the system is out of warranty. You mentioned earlier that the motherboard was replaced - did you purchase this from Dell or from a third-party company? The reason I ask is that I would say that the changes aren't saving and the battery has been replaced then we're looking at a faulty motherboard.

If you purchased it from Dell, please send me the order number in another private message and we'll take it from there. If you didn't, I would advise you to contact the company that you purchased the motherboard from to see about a refund or exchange.

John C
Dell | Social Outreach Services


Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
GWizITBiz
1 Nickel

Re: Studio XPS 9000/435T - Can't disable onboard lan!?

Thanks for your help John. I appreciate the effort!

but I SOLVED my problem...

I googled this problem and found the solution. As goofy as it sounds, it fixed my problem. Here it is:

- Go into BIOS, Load defaults, save, boot up computer

- On the next boot, go back into BIOS, change "Onboard LAN Boot ROM" to DISABLED, save changes and continue to boot.

- Now the "Onboard LAN Boot ROM" change to disabled stays put and doesn't reset itself to enabled.

- All subsequent boots DO NOT try to boot off the LAN

following is thh link where I found this solution:

serverfault.com/.../dell-pc-booting-to-intel-pe-boot-agent

0 Kudos
Moderator
Moderator

Re: Studio XPS 9000/435T - Can't disable onboard lan!?

Hi Greg,

I'm really glad to hear that! This is one of those problems that has a seemingly simple fix but it's taken a great deal of experimentation to find that out!

Thank you for posting the fix here, however, as I'm sure if it comes up again that it will be of use to other customers. It's certainly been useful for me as it's a great reminder not to take simple fixes like that for granted.

Have a great weekend and thanks again for using Dell.

John C
Dell | Social Outreach Services


Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
Jim Wichita
1 Copper

RE: Studio XPS 9000/435T - Can't disable onboard lan!?

yep that worked for me too.

Had to disable the Onboard LAN Boot ROM just as you outlined.

Worked on next reboot!

Thanks so much!

0 Kudos
kreg37
1 Copper

RE: Studio XPS 9000/435T - Can't disable onboard lan!?

Thank you, thank you very much.  I had a different, but similar issue.  I had to replace the motherboard for my Dell XPS 9100, and it would always attempt to boot via PXE (LAN) every time I turned it on.  My options were to wait for it to time out or hit escape to abort.  Very annoying, but I lived with it for almost two years without finding a solution.  Your recommendation to go into BIOS, select "Load Defaults," save, and boot up computer fixed the problem.  That's all I had to do.  I had already selected "disable" PXE boot in the BIOS (even though it previously didn't work), and it was still selected after pressing "Load Defaults."  Anyway, the PC no longer attempts the PXE boot and now boots straight into Windows.

0 Kudos