gkiely24
1 Copper

Took apart H2C cooling system and found a problem

Jump to solution

I have a dell xps 720 h2c. Using coretemp I noticed that during folding at stock clocks my cpu temp would jump up to around 75C on all cores. I purchased the non H2C cooler off ebay and installed it. My temps went down 20C now my cpu sits at 55C (QX6850 btw). I wanted to see what was wrong with my H2C unit that was causing the high temps. I drained the fuild from it and disassembled it. The pump, radiator, and peltier unit all seemed to work correctly. Then I got to the water block. There is a filter installed in the incoming line, this has little bits of stuff in it so I cleaned it out and tried to blow through it, it was impossible, it seemed like no air was going through it. I can't see how any water would pass through it. When I disassembled it further I found the plate on the inside was covered with corrosion. The micro chanels were for the most part blocked. I cleaned everything out and tested it outside the system. With the pump at full power, the water basically trickled out of the block. The flow was extremely low, any lower and it would probably just drip out. I can't see how this is good for cooling, especially a processor with a TDP 130 watts. I feel the block is the weakest part of the H2C system. I would like to try a different block with the system, but I can't see spending around $100 to fix a cooler that should have worked in the first place. I am very disappointed in dell especially after spending over $3000 on this system.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
spacehooter
1 Copper

Re: Took apart H2C cooling system and found a problem

Jump to solution

The H2C is in my opinion an accident waiting to happen. 1: its pressurised. 2: it can't be refilled or serviced 3: its built to fail just outside the warrantee. 4: I now know its performance was poor compared to average water cooled units.

Until now!

I have 2 XPS730H2C's my son has one and I the other. when his system registered a pump failure it would not boot but just shut down. turning the computer on its side allowed it to boot and the pump failure went away. so I resolved to fix the system myself. I swapped him my cooler and worked on his.

1: remove h2c cooler (you will need a very long crosshead screwdriver. clean tim off with isopropanol. push down on center of valve located on tec plate. push until you relieve the pressure inside (do this outside your home!)

2: install a reservoir before the pump (I used an innovatek one with 3/8" ID - 1/2"OD tubing and fittings) cut rubber pipe carefully with sharp craft knife then remove old tubing. don't damage the fittings themselves or it will leak!

3: remove tubing from inlet to chipset block and remove inline strainer from inlet.

4: Remove base plate from CPU block (4 screws) and carefully, with a sharp object prise out the plastic insert which so some unknown reason is there in the first place!. don't damage the outer seal "o"ring and replace the base plate (observe orientation- notch in plate)

5: put H2C back in and refill. it is advisable to try and blow through the whole assembly prior to installing it just to see if there are any more restrictions.

You will need at least 3m of tubing, the clamps on the h2c can be reused with the new tubing. some anti kink coiling is a good idea to stop and pinching of the tubing. a very deep reservoir is needed as when the system is very hot or tweaked (nvidia esa) the pump runs even quicker causing turbulence in the reservoir pushing air into the system. i have taken all the Nvidia performance/ntune/system monitor off of my system because it causes constant crashing (not just since I fixed the cooler)

As far as I know I am the only person to ever fix this cooling system. I have looked everywhere. There is a youtube video series of someone supposedly fixing one but it was not successful as he didn't know about the cpu block restriction or filter. also he was an idiot and made assumptions about the technology without any real experience. another upgrade that should be done is to remove the foil layer from on top of the chipset plate and scrape off the glue with a blunt knife. this will lead to a problem where the cooler will no longer make contact properly with the chipset. I fixed this by bending off one of the fins from the TEC cooler and trimming it down until it would fit in top with a pair of tin snips. tim underneath, tim on top & tim the cooling block (sandwich the piece of tin)

My system never gets hotter than 45c degrees under full load. BF3

Here is a picture of the system running (not pretty but I will get around to that later).

http://www.kernowbathrooms.co.uk/dellpic.html

4 Replies
Highlighted
spacehooter
1 Copper

Re: Took apart H2C cooling system and found a problem

Jump to solution

The H2C is in my opinion an accident waiting to happen. 1: its pressurised. 2: it can't be refilled or serviced 3: its built to fail just outside the warrantee. 4: I now know its performance was poor compared to average water cooled units.

Until now!

I have 2 XPS730H2C's my son has one and I the other. when his system registered a pump failure it would not boot but just shut down. turning the computer on its side allowed it to boot and the pump failure went away. so I resolved to fix the system myself. I swapped him my cooler and worked on his.

1: remove h2c cooler (you will need a very long crosshead screwdriver. clean tim off with isopropanol. push down on center of valve located on tec plate. push until you relieve the pressure inside (do this outside your home!)

2: install a reservoir before the pump (I used an innovatek one with 3/8" ID - 1/2"OD tubing and fittings) cut rubber pipe carefully with sharp craft knife then remove old tubing. don't damage the fittings themselves or it will leak!

3: remove tubing from inlet to chipset block and remove inline strainer from inlet.

4: Remove base plate from CPU block (4 screws) and carefully, with a sharp object prise out the plastic insert which so some unknown reason is there in the first place!. don't damage the outer seal "o"ring and replace the base plate (observe orientation- notch in plate)

5: put H2C back in and refill. it is advisable to try and blow through the whole assembly prior to installing it just to see if there are any more restrictions.

You will need at least 3m of tubing, the clamps on the h2c can be reused with the new tubing. some anti kink coiling is a good idea to stop and pinching of the tubing. a very deep reservoir is needed as when the system is very hot or tweaked (nvidia esa) the pump runs even quicker causing turbulence in the reservoir pushing air into the system. i have taken all the Nvidia performance/ntune/system monitor off of my system because it causes constant crashing (not just since I fixed the cooler)

As far as I know I am the only person to ever fix this cooling system. I have looked everywhere. There is a youtube video series of someone supposedly fixing one but it was not successful as he didn't know about the cpu block restriction or filter. also he was an idiot and made assumptions about the technology without any real experience. another upgrade that should be done is to remove the foil layer from on top of the chipset plate and scrape off the glue with a blunt knife. this will lead to a problem where the cooler will no longer make contact properly with the chipset. I fixed this by bending off one of the fins from the TEC cooler and trimming it down until it would fit in top with a pair of tin snips. tim underneath, tim on top & tim the cooling block (sandwich the piece of tin)

My system never gets hotter than 45c degrees under full load. BF3

Here is a picture of the system running (not pretty but I will get around to that later).

http://www.kernowbathrooms.co.uk/dellpic.html

gkiely24
1 Copper

Re: Took apart H2C cooling system and found a problem

Jump to solution

Wow it looks like you spent a lot of time fixing, what should have been a working system. I swapped out the H2C for the stock air unit, and it dropped the temps 20C. I couldn't believe how poorly the stock H2C worked.  I have since moved on from dell and built my own system, 2500k, GTX 580, SSD, the works haha. It performs better then my dell ever did and ever could have. I wish I had done it sooner.

0 Kudos
speedstep
6 Thallium

Re: Took apart H2C cooling system and found a problem

Jump to solution

Here is your picture.

Looks Like a lot of work.


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Anonymous
6 Gallium

Re: Took apart H2C cooling system and found a problem

Jump to solution

A little late but I still hope you exist. I am also attempting to re-build my H2C unit. Dell quoted my over $1K for a replacement . Kind of explains why they are not doing so good as of late.

I've started to follow your repair instructions and have a question. In step 4, "remove the CPU.." you mention prying out the "plastic insert". Would that be the one on the bottom (inside) copper cover plate? I can't tell if it is plastic or not. When I remover the copper top there was some sort of material in there, either dissolved plastic or crud.

Any other helpful tips would be appreciated.  $5K for the PC to last 3.5 years and no parts.....unbelievable. Dell has lost a loyal customer who purchases for a large gov. department.

0 Kudos