Highlighted
tojohnson78
1 Copper

Video card and RAM upgrade issues on my Studio XPS 435MT

Greetings!  I'll try to keep this as short and sweet as possible.  Hoping someone might have some answers for me.

My computer - Dell Studio XPS 435MT

Computer is stock except for the following upgrades

- XFX Radeon 6870 @ 1GB

- Corsair 600W PSU

 

Since I like this computer so much, I decided to upgrade again vs building a new machine.  Below are the video card and memory I purchased.

EVGA GTX 680 @ 4MB  http://www.newegg.com/Product/Product.aspx?Item=N82E16814130794

G Skill PC3 10600 RAM (3 4GB sticks for a total of 12GB)  http://www.newegg.com/Product/Product.aspx?Item=N82E16820231421

 

I am having issues with both the video card and RAM.  With the video card, I uninstalled the old Radeon drivers and any related software, installed the GTX and installed the latest GTX drivers.  Everything seemed to be working fine (I have Windows 7 64 bit) until I tried to play the only game I play on my PC which is Eve Online.  When I am at the character selection screen, the background was a weird color of green instead of black.  Once in the game, there is a green and red colored haze all over the screen.  I can barely see underneath this weird haze!  The weird thing is, none of the menus in Eve seem to be affected by this weird coloring.  Just seems to be an issue with the main graphics of the game.  I have tried reinstalling everything again but that did not help.  I reinstalled by Radeon 6870 and everything was fine now.

I installed the 3 sticks in the 3 slots closest to the CPU.  There are a total of 6 slots on the stock motherboard.  Windows and the BIOS are only recognizing 8GB of RAM and I cannot figure out why it is not picking up the other 4GB stick.

 

Questions

1) Is the GTX 680 card even compatible with the factory motherboard on my Studio XPS 435MT?  My initial thought is to RMA the card for a refund and bu another type/brand of card like a GTX 770.  But I am now concerned that the newer cards are not compatible with the factory board on my XPS Studio 435MT.  Any expereince of insight here would be GREATLY appreciated.

2)  Is my memory issue due to the BIOS needing updating (hasnt been updated since 2009) or is the memory I bought not compatible with my board?

 

Thanks in advance!

 

 

 

0 Kudos
4 Replies
rdunnill
5 Iridium

Re: Video card and RAM upgrade issues on my Studio XPS 435MT

If you haven't already, I'd suggest updating your BIOS to the latest version. And if you have access to a spare hard drive, I'd suggest trying a clean install.

However, your issues may be due to incompatibilities with the video card: sometimes that's the way it is.

0 Kudos
Troy Wiebe
1 Copper

Re: Video card and RAM upgrade issues on my Studio XPS 435MT

You should install the ram in slot #1, #2, #3, slot order from cpu are 4,1,5,2,6,3. Try That.

0 Kudos
Lordfredplus
1 Copper

RE: Video card and RAM upgrade issues on my Studio XPS 435MT

Hello I have a similar issue, my 435mt is only seeing 4 of 6GBs. I have 6 1GB sticks all the same and from install. The 1st two slots (closest to the CPU) are not recognizing the sticks. I tried the same stick on the other slots and they are recognized, but not the first two. The only hardware changes I done was change was upgrade my video card (to Radeon HD 7770). I have since swapped out the motherboard, but it had the same problem, any help is greatly appreciated. Smiley Happy

0 Kudos
argvargc
2 Iron

RE: Video card and RAM upgrade issues on my Studio XPS 435MT

I am curious to know what happened to the RAM upgrade project. 

I am now looking at a RAM upgrade myself for 435MT.

0 Kudos