Alicami
2 Bronze

Wireless keyboard not typing in windows search box

Hi,

after windows 10 Anniversary Update on my XPS 2720 I started having trouble with the wireless keyboard. When using windows search box or windows mail, I can only type a few letters then the keyboard stops working (except for a few keys, like the space bar, backspace, +, -). The keyboard works fine in all other applications (microsoft office, browsers and so on). The problem is not present in safe mode.

Drivers are up to date and I already tried this (copied from another similar thread within the Microsoft community):

Method 1:

  • Press Windows + X keys on the keyboard, select Command prompt (admin).

  • Enter the below commands one by one and hit Enter key.

    PowerShell -ExecutionPolicy Unrestricted

  • It will open the PowerShell window.

  • Now enter the below command and hit Enter key.

    Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "*SystemApps*"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

If the issue still persist, follow the below method.

Method 2:

  • Open the Task manager.  Here’s a tip:  Press CTRL+Shift+ESC.
  • Click File > Run New Task
  • Make sure you have a check mark beside “Create this task with administrative privileges”
  • Type Powershell
  • Type the following in the Powershell prompt:
    $manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest
  • Close the Powershell window
  • Reboot the computer and check if it helps.

I forgot to mention that the virtual keyboard works fine both in windows mail and windows search box, so I would rule out a problem with those applications.

Any help is highly appreciated.

0 Kudos
1 Reply
Alicami
2 Bronze

RE: Wireless keyboard not typing in windows search box

Hi,

problem solved unistalling logitech driver and leaving the control of the keyboard to the operating system.

Regards