Highlighted
sflitteral
2 Bronze

XPS 18 Tablet not charging while plugged in??

Jump to solution

Hello folks,

I need help with a problem. When I plug in the charger to the tablet directly is shows "plugged in but not charging" but when i plug it into the cradle it works fine. I was wondering if this is a software switch that I might have activated. I have just updated the drivers, bios and disconnected and plugged back in the battery. Still have the same issue. I also checked the charger and it is working as should be.........

Please help.

0 Kudos
142 Replies
sflitteral
2 Bronze

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

So any ideas that might help me?

0 Kudos
caminhante
1 Copper

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

any news? same issue with my xps18

0 Kudos
dejan1980
1 Copper

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution
I have the same issue as sflitteral; charging while in stand, not charging while directly plugged in. I updated all drivers and at the end decided to update BIOS (A05 to A06). After updating BIOS and restarting tablet I noticed battery did start to but only for a minute or two. It seems like something switched it off. AC adapter seems to be recognized in BIOS (showing 65W). I also run battery diagnostic test and results indicate its OK.
7- Thorium

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

I pinged my Dell tech contacts about this issue.

Stay tuned...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
terrordyne
1 Copper

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

Any news on this. I have the same issue. "Plugged in not charging" on the XPS 18 on the cradle or just plugged into the side. I have 2 of these, so I swapped the chargers to test that. Both XPS18s are running Windows 8.1 with all updates/all current Dell drivers and A06 bios.

Any suggestions to try, other than to turn this into a Frisbee and see how far it flies out the window, would be most appreciated!

Thanks!

0 Kudos
7- Thorium

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

Any news on this. I have the same issue. "Plugged in not charging" on the XPS 18 on the cradle or just plugged into the side. I have 2 of these, so I swapped the chargers to test that. Both XPS18s are running Windows 8.1 with all updates/all current Dell drivers and A06 bios.

Any suggestions to try, other than to turn this into a Frisbee and see how far it flies out the window, would be most appreciated!

Thanks!

@Terrordyne- Are you saying it won't charge either in the cradle or directly plugged in? That seems to be different from what the others said because their unit will charge in the cradle.

Either way, my Dell tech contact says he's notified the appropriate team to look into this issue. 

I don't have an ETA for a  response, but hang in there...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
svImajica
1 Copper

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

My XPS18 decided to stop charging three days ago.  I just ordered a cradle and new charger to see if I could bring it back to life.  Right now, it does not have enough power to boot. 


Shouldn't it be able to boot on the power adapter regardless of battery state?

0 Kudos
7- Thorium

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

Shouldn't it be able to boot on the power adapter regardless of battery state?

That should be correct, but assumes the charger is working and/or the onboard circuitry is accepting power from the charger...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
svImajica
1 Copper

RE: XPS 18 Tablet not charging while plugged in??

Jump to solution

I purchased one of the Dell stands with charger and the XPS18 charged fine while on the base.

Put a DVM on the original charger and the new charger that came with the Dell stand...same readings.

Now, with computer fully charged, when I plug in the old (or new charger), the power led remains white (before on the old charger, it was slow blinking red).

This is a real confidence destroyer.  I had hoped to carry this for business and presentations, but if I have to drag along the 8 pound (and bulky) stand to be able to charge the thing, it is a no-go.

I would just like to know if it is a software or hardware problem... 

0 Kudos