DiAngelo
2 Bronze

XPS 27 7760: PCI Bride removed and reinstalled at Startup

My system:  Dell XPS 27 (7760)

Bios: 2.02 (Latest available)

OS: Windows 10 Home

PCI Bridge Driver: 10.1.1.18 (dated 4/4/16)

 

The system event log  reports that a previous shutdown was unexpected, however I did power off the system normally. When I turn the PC back on it indicates that the PCI bridge was removed and reinstalled. This happens frequently and updating my Bios does not fix it.

Support Assist also claims that updates are available for the Intel Chipset management engine (11.6.0.1047, A01), but this is already installed.  Uninstalling it and reinstalling it does nothing.

Any ideas?

Thanks,

DiAngelo

 

 

0 Kudos
4 Replies
Mary G
6 Indium

RE: XPS 27 7760: PCI Bride removed and reinstalled at Startup

Go to Dell Support here and let it detect the correct drivers. www.dell.com/.../drivers

0 Kudos
DiAngelo
2 Bronze

RE: XPS 27 7760: PCI Bride removed and reinstalled at Startup

Did that..."No driver updates found. Your system has the most recent updates."

0 Kudos
7- Thorium

RE: XPS 27 7760: PCI Bride removed and reinstalled at Startup

Go to Intel's download site and let their wizard scan the hardware for suitable drivers...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
DiAngelo
2 Bronze

RE: XPS 27 7760: PCI Bride removed and reinstalled at Startup

I updated the Intel drivers since the drivers on the Dell website are not the latest. Will test over the next few days to see if this solves the problem. I have seen from different threads that the Support Assist often instructs users to install older drivers, or drivers that may have already been installed.

Thanks,

DiAngelo

0 Kudos