Highlighted
cARLwINSLOW
1 Copper

XPS 420 DVI No Longer Working on BFG 9800GT w/ 2408wfp-hc

Last night, I changed rooms for my desk area.  After shutting down the PC, moving it, and turning it back on, It failed to start.

I've had the same DVI cable, card, and monitor setup for over a year now, with numerous reboots, updates, and moves.

The PC powers up, system check lights 1,2,3 stay solid, and monitor shows nothing.  If I unplug the DVI cable from the card or the monitor, the tower boots.  After I hear the Windows startup music, I can plug the DVI cable in and get a display to show with 1024 x 768 res.  I can log in to Windows (64bit-Vista Business) and get to the nVidia control panel.

The monitor shows as a Generic P'n'P monitor with no resolutions available other than 800x600 and 1024x768.  I can't force it to use any new resolutions either.  I try to restart the PC and it hangs again with a black screen and 1,2,3 status lights lit.  The PC will simply not boot with the DVI cable attached to the monitor.


I tried to use another DVI cable to no avail, thinking it may have gone bad.  Then I switched to a VGA cable with a DVI adapter on the card end, and the PC boots normally with the same monitor.

I just can't get the DVI to work, when it worked for two-plus years before that.

Is there an EDID problem all of a sudden?  I haven't updated anything or installed anything since my last reboot. 

I'm clueless at this point.

0 Kudos