yann.r
1 Copper

Re: XPS 420 SATA RAID and drive failing

Hello Nigelwill,

 

Have you been able to give a try to the new A04 Bios?

Dell XPS 420 System BIOS - A04

 

Not sure this is intented to solve HDD issues...

0 Kudos
nigelwill
2 Bronze

Re: XPS 420 SATA RAID and drive failing

Thanks, I haven't checked the XPS page for updates this week, but I will give that a try.  Do we have any idea what it's supposed to fix?
0 Kudos
brl21
1 Copper

Re: XPS 420 SATA RAID and drive failing

I will give that a try later - Thanks.
0 Kudos
RetRoe
2 Iron

Re: XPS 420 SATA RAID and drive failing

Well y'all had Samsung drives and then some of ya that had them replaced with Seagate? I can't relate because I just went into Device Manager and looked and guess what came in my Dell XPS 420? Neither of those! Mine states it's running: WDC WDC3200AAKS-75VYA0 which is a Western Digital Caviar SE16 320GB HDD. Gee, I wonder why Dell loaded it with this particular drive when y'all say your came with Samsung drives?

 

I only have a single drive so obviously no RAID array here. But I have not noticed any freezing or lockups so far. Also, obviously I'm not upgrading firmware on my drive unless I find a reason to do so. And my BIOS is A03.

 

If I wanted to add another HDD, I don't know, but I don't think I'd be able to run it in a RAID array now unless I wanted to reformat and reinstall Vista. So for now all is good.

0 Kudos
brl21
1 Copper

Re: XPS 420 SATA RAID and drive failing

I'm beginning to wish I had gone non-RAID as well!

 

Mine came with 2 seagate 320gb drives as standard, but still has the same issues.

 

I did the A04 BIOS and chipshet updates last night - no idea if it has helped at all, but will keep you posted.

 

Could Dell tell us what this new BIOS update is supposed to do? Is it aiming to fix any specific problems with the 420?

Message Edited by brl21 on 04-10-2008 12:18 PM
0 Kudos
nigelwill
2 Bronze

Re: XPS 420 SATA RAID and drive failing

I've done all the upgrades including the BIOS. No idea if it has made a difference yet, it can work for 5 days in a row then crash twice in an hour!

 

But I will post back in a week with any good/bad news!

0 Kudos
Davet50
6 Indium

Re: XPS 420 SATA RAID and drive failing


@brl21 wrote:

 

Could Dell tell us what this new BIOS update is supposed to do? Is it aiming to fix any specific problems with the 420?

Message Edited by brl21 on 04-10-2008 12:18 PM

Chris M posted an answer to this...performance enchanments and support for Yorkfield processors

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

0 Kudos
Highlighted
MVick71
1 Copper

Re: XPS 420 SATA RAID and drive failing

Way, way back on page 10, I got the raging hump with my XPS's inability to manage my RAID1 disks, so I broke the RAID (just an aside, if you have RAID 1 and you do this, you don't need to reinstall. You get 2 disks with the same data. Just blow away the 2nd disk).

 

I've now been running with bog standard single disks (admittedly, not whatI really wanted) and everything has been fine for 2 months now.

 

Just thought I'd let you all know.

0 Kudos
paulbeattie87
3 Argentium

Re: XPS 420 SATA RAID and drive failing

For those intrested I flashed my Samsung hard drives and since then they have been working flawlessly. Using the patch I posted earlier and not a single problem yet. My 420 has been running for about 6 days solid now, did have 122 hours uptime before Windows updated and it has yet to slowdown or freeze up yet!!!

 

I have 2 500GB Samsungs non RAID. 

0 Kudos
Shootyz
1 Copper

Re: XPS 420 SATA RAID and drive failing

 Same here, I was experiencing daily hangups before the Samsung upgrade and now everything seems to be rock solid, Im running 2 500GB Samsungs RAID 0.
0 Kudos