Truc88
1 Nickel

Re: XPS 435 Owners Thread

I was planning to upgrade my 435MT from 4GB to 6GB with the Dell Parts.
Before, the Dell price of 1GB was around $20-$25, but now the price just went ballistic : $75 / piece : see link
http://accessories.us.dell.com/sna/products/Memory_Upgrades/productdetail.aspx?c=us&l=en&s=dhs&cs=19&sku=A2290225&mfgpid=200594

So now I am looking at external vendors and they have these 1GB DDR3 by the unit or by pack of 3x1GB.
Question 1: did any experience any issue to go from 4GB to 6GB by adding 2 x 1GB from an other vendor than the Dell RAM, along with the 4 x 1GB RAM of Dell ?
Or is it better to go to 6GB with a new pack of 3x1GB (from the vendor below) and keep 1GB from the original Dell RAM as spare ?

Question 2: Did anyone on this forum use the following type of RAM :
Crucial 1GB 240-Pin DDR3 SDRAM DDR3 1066 (PC3 8500) Desktop Memory Model CT12864BA1067
or Crucial 3GB (3 x 1GB) 240-Pin DDR3 SDRAM DDR3 1066 (PC3 8500) Triple Channel Kit Desktop Memory Mode...
Or if you have any other recommendations in terms of RAM (1066 MHz PC3 8500 1.5V).
Thanks in advance.

0 Kudos
fishnbanjo
3 Silver

Re: XPS 435 Owners Thread

Crucial has an online memory diagnostic which scans the PC to match the memory correctly to it I suggest doing that with your system. I have used Crucial for my XPS Gen 1 laptop upgrades and my XPS 600 as well w/o any issues the memory they specified worked exceptionally well. I did check my 435T when I first got it but Crucial stated none of the memory they currently had was compatible but I'm sure this has either changed or will soon enough. The other alternative RAM I've seen bandied about are OCZ and Corsair if I remember right but a quick review of the lengthy 435T owners thread will tell you for sure, good luck.

435T i7 975 3.3 GHz Extreme, 12 Gb RAM, 1.5 Tb SATA x 2 internal,Patriot Warp 256 Gb SSD quick release and 1.5 Tb eSATA drive  Windows 7 64 Ultimate, Blu-ray/HD-DVD/RW combo by LG and Blu-ray/RW, 1000/NIC and  Belkin N+  wireless, X-Fi Extreme Soundblaster, Hauppauge 2250 DTV Tuner card with Media Center remote, Bose Surround Sound 5.1 speakers, LifeCam VX 3000 VidCam, Logitech Wireless Desktop Kb and Performance MX Mouse, Bamboo Pen Tablet,  XFX ATi 5870 XXX Edition driving a Vizio 37" HDTV using  Optical Toslink from the X-Fi Extreme Sound Card, also have Pioneer SE-DIR 800C Wireless Dolby DTS Headphones

 

Black Alienware M17X Q9100 2.26 GHz Extreme, 320Gb HDD0 and 160Gb SSD1,Blu-Ray w/ DVD/RW, 8Gb RAM, WUXGA  Screen, ATI 4870 Crossfire-x,  Alienware TactX Mouse Windows 7 64 Professional.


0 Kudos
Truc88
1 Nickel

Re: XPS 435 Owners Thread

Fishnbanjo,
Thanks for the suggestions. Indeed, I went to Crucial, used their configurator, it came up with many "compatible" suggestions for my 435 MT i7 920. And the only one I am interested in (1066 MHz / PC3-8500) has a exact similar model (same specs, same price) but a second different P/N on their web site.
And the second P/N is the only one I can find at Newegg (not the first one, not sure why).
For the older posts, I looked into them, and most, if not all of them, were more about upgrading with 1333 MHz RAM, which is not the option I am looking for.
I'd like to keep the existing RAM, and add 2 or 3 GB with the same specs 1066 MHz, with the minimal compatibility issue.

0 Kudos
mbenghaly
1 Nickel

Re: XPS 435 Owners Thread

I'm posting today mainly because I was bored and tried to run the Creative(soundblaster) Software AutoUpdate and got a BSOD!!!!!  I was surprised because that was the first one I've seen on my new XPS 9000.  After the restart I tried to run it again and it gave me another BSOD.  So now I'm confused by the fact that this program apparently is trying to screw up Vista somehow.  Anybody else seen this issue?!?

0 Kudos
LathropDave
1 Nickel

Re: XPS 435 Owners Thread

Yes it happened on mine too. Don't do any updates from Creative. I just let Windows do updates to the sound drivers and all is well. I've never had a problem with Creative updates like this in the past (been doing this for 25 years) so I have to agree with previous comments about Dell's quality control. To get a BSOD on a update is inexecusable. Somethings wrong with the sound software they put on these pc's.

 

0 Kudos
D99X
1 Nickel

Re: XPS 435 Owners Thread

I'd be careful about mixing with the Dell RAM via a 4 (Dell) + 2 (new) thing. I'd keep them in identical groupings of 3 for triple channel.

Also be very careful about what places like Crucial say are compatible. There are reports the voltage must be 1.5V on the 435 boards, and many of those supposedly "compatible" indicate they're 1.65V.

And lastly, if you're looking for RAM on Dell's website, once you find what you think you want do a search for the same thing based on the manufacturer part number. You'll often find the identical thing listing at a lower price when it's indicated for another system. But it's exactly the same product otherwise. For example, the 2GB RAM modules listing for the 435 / 9000 are $10 cheaper when listed for a couple Alienware models. But the RAM is the same.

0 Kudos
kentfyfe
1 Copper

Re: XPS 435 Owners Thread

yup - the Creative update is a DDT, as it will BSOD everytime.  Outside of the Creative BSOD, I've been fairly lucky and can count on one hand the BSOD's I've gotten since took delivery.  Really shouldn't of had any though - My old HP with XP was a much more stable platform.  Oh, well... Dell is a different company than it used to be, and some key components to their previous successes have gone out the window.

0 Kudos
mbenghaly
1 Nickel

Re: XPS 435 Owners Thread

Today I read through the recent posts to see if anybody had a good fix for the BSOD upon running the Creative AutoUpdate and saw that installing the Realtek USB Card reader driver update might fix the problem. 

So I downloaded and installed the Realtek USB 2.0 Card Reader updated driver and the card reader seems to work fine.  Then I tried to run the Creative(soundblaster) Software AutoUpdate and DIDN'T get a BSOD. 

However, the Creative AutoUpdate now doesn't find any SoundBlaster hardware installed on my PC.  Apparently it has disappeared.  But at least no BSOD so that's a big improvement.

0 Kudos
Truc88
1 Nickel

Re: XPS 435 Owners Thread

D99X,
Thanks for the tip on the Manufacturer part. I found 3 different items, 1 for the Studio XPS / 435T/9000 at $75, 1 for the XPS430 and 1 for the XPS 730X, both at $25.
And all 3 have the same Mfg P/N and the exact same description, and I confirm with a Dell rep, it is a 1.5V.
So I ordered 2 of those for the "XPS 430". Hopefully with CPU-Z I will see if they are absolutely the same than my original 4x1GB sticks.
(Note : for others who are interested in the Crucial, those 2 references of Newegg I put in my above post, they are also 1.5V. And they are the exact same than the versions recommended by the Crucial configurator but simply with a  different P/N, I confirmed this with a Crucial rep).

0 Kudos
mbenghaly
1 Nickel

Re: XPS 435 Owners Thread

Just to let all ya'all know.  I was able to order my Win7 upgrade disc today.  Hope I gets it soon!

Tags (1)
0 Kudos