shu1
1 Nickel

XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

On my XPS 8300, after upgrading to Windows 10, the network would just stop working after a while (seemingly after some network load, but was never able to pinpoint it).  Restarting the PC would enable the network, but then it would eventually disconnect again, sometimes in as little as 5 minutes.

So I tried installing the Win7 network driver from Dell's site, and I no longer get disconnected.  Search for "R282233", or just download the file from this link.

http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=NDC29

Dell writes that Win10 is not supported on the XPS 8300, but after fixing this network problem, I don't have any other issues.

EDIT 2015-08-30

Let me try to summarize this thread so far.

Installing R282233 (14.2.0.7) fixed the disconnect problem for 11 people:
- shu
- ClutchRaider
- Ickabod
- digitalexplr
- JohnGosselin
- tj_moore
- Mr.JASmith
- digger1978
- rrao
- RunsLikeDell
- andpen

It did not fix it for 2 people:
- sig94nl
- miami3170

tj_moore and RunsLikeDell reported that just running the installer did not actually change the driver version. They had to first uninstall the previous drivers and all Broadcom software, or even that wasn't enough and had to select the "Repair" option in the Broadcom install package, as opposed to the "Modify" option.

I personally just ran the installer without doing anything special, and it did change the driver to 14.2.0.7. I assume most people did too. I don't know what the difference is, perhaps doing a clean install of Windows 10 helped.

Mr.JASmith reported that both 17.2.0.0 and 15.6.1.2 did not work for his XPS 8000. RunsLikeDell also reported 15.6.1.2 did not work for the XPS 8000.

But in another thread, MikeZ and B23x say 17.2.0.0 does work for the XPS 8300.

http://en.community.dell.com/support-forums/software-os/f/4997/p/19644811/20809376#20809376

If anyone else updates their XPS 8300 to 17.2.0.0, and it does fix the disconnect, please report back.

62 Replies
digitalexplr
1 Nickel

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

Thanks for the tip. My XPS 8300 was doing similar thing. I have rolled back to 8.1 Pro for the present time, but would like to get it back on Win 10.

0 Kudos
ClutchRaider
1 Copper

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

Following up, is your Windows 10 working properly now on your Dell XPS 8300?  Just tried this myself and it seems to be working so far.

0 Kudos
Duncan Band
1 Copper

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

Thanks for this. Been having the exact same problem. Will give the driver a try.

ClutchRaider
1 Copper

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

This seems to have done it for me, good luck to you!

Thanks to OP.

shu1
1 Nickel

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

I reworded my original post to make clear that the network and everything is working fine in Win10 now.  I'm glad it seems to be working for others too.

This exact problem also seems to be happening on other Dell PCs with a Broadcom adapter.  I've seen reports of it on the Inspiron 580 too.  Hopefully installing older drivers fixes it for others as well.

0 Kudos
sig94nl
1 Copper

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

I've tried everything I can think of, installed and reinstalled these drivers along with other things several times, but nothing seems to work.. Basically my PC is now nothing but a glorified Microsoft Paint machine. Am I perhaps missing something?

0 Kudos
Ickabod
1 Copper

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

I wish I could shake your hand.  Been obsessing with this for a few days now.. Couldn't find anything until this post fixed it.. TY!

digitalexplr
1 Nickel

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

Got my 8300 back on Win10. Didn't need to install the Broadcomm driver. I think my network issues were because of problem with Bitdefender. There is an issue with Bitdefender and Win10, but Bitdefender has a fix that solves the problem.

The 8300 has been up and running on Win 10 for several hours and has not had a network issue.

0 Kudos
Highlighted
shu1
1 Nickel

RE: XPS 8300 Windows 10 Broadcom network adapter disconnect FIXED

I think I didn't have network disconnects the first day either.  I think it started happening as I gradually installed Dropbox, Google Drive, OneDrive, Chrome, Slack, TweetDeck, etc.  Network apps that are always running.  After the Win7 driver was installed, all these apps run fine simultaneously.  I did a clean install of Win10, and didn't install any additional anti-virus software or anything.

Or maybe Microsoft made updates to Win10's network drivers that fixed the problem by now?  Does anyone else's Broadcom adapter not get disconnected, without installing old network drivers?

@sig94nl, you installed the Win7 network driver linked above, and you're still getting the same disconnects?