khisel
1 Nickel

XPS 8700 "Keyboard Failure"

Trying to solve the 12-second or so booting delay with BIOS A08 (well documented in these forums) I installed BIOS A03. While it booted faster, it displayed a "Keyboard Failure" message after the Dell logo went away (keyboard works fine once in Windows). I got a little spooked by that so I reinstalled A08 but now I still have the "Keyboard Failure" message upon restarting the computer. The good news is if I shut down, wait about 30-60 seconds before powering back up, all is well until the next restart.


Since I have discovered the workaround, functionally there is no issue, however, seeing that "Keyboard Failure" message upon every reboot is disconcerting. I know I can turn off the warning, but I'll still know something is not right.

BTW, I'm running Win 7 Pro, not 8. I've reloaded/saved the default BIOS settings and no joy.

I'm pretty certain I have only myself to blame. But the root cause of my mischievous actions (delayed booting) is still inexcusable on Dell's part.

0 Kudos
2 Replies
RoHe
6 Indium

RE: XPS 8700 "Keyboard Failure"

If you reboot and press F2, can you open BIOS setup?

Once in setup, copy down all the current settings. Then use the option to Load Default Settings, on the exit screen. That should clear the error message. After you exit and reboot, go back into BIOS setup and make sure all settings match what you copied or change to match and be sure to save the changes on exit.

Even assuming that clears the current keyboard error message, you can prevent it from ever appearing again by disabling the BIOS option to show Keyboard Errors on boot, even if a keyboard problem is detected on some future boot.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
khisel
1 Nickel

RE: XPS 8700 "Keyboard Failure"

Loading the defaults back into the BIOS screen (tried this twice) doesn't fix the problem. The keyboard is unrecognized during a reset/bootup and the error message still appears.


Yes, I know I can suppress the display of the message but that's hardly a fix.


Luckily the workaround (shut down, wait 30-60 seconds, then boot) works so it's not impacting the functionality of the computer, just irritating my sensibilities.

0 Kudos