Highlighted
rednosedpits
6 Indium

post boot error message

Yesterday I replaced the cdrw drive that came with the system with a liteon dvdrw drive, after booting into windows the first time no issues all drives show up and work in explorer, when I needed to restart the system and everytime now I get this error with the number of the drive changing each time. " drive 2 not found serial ata sata (0),(1),(2) . I have an optiplex 755 running bios version A22 unfortunately cannot get support from dell because the system is too old for them to allow me to pay for a contract with them, so how do I get rid of the message it always appears when it is doing pxe?

16 Replies

RE: post boot error message

Hi Rednosedpits

Thanks for writing to us. 

Please go to BIOS and check if the Hard drive and DVD drivers are detected. If not please reseat the cables and post that run the diagnostics for any hardware issues. 

Post that, once the machine goes into windows check in device manager under properties of DVD Drive for any error codes.

Regards

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
rednosedpits
6 Indium

RE: post boot error message

within windows and in device manager the dvdrw drive shows up and can play any disk and the hard drive shows no issues it is just when booting up that I get the problems, I checked bios for drives and it shows sata 0 = dvdrw drive (problem when post), sata 1 = WD 1 TB drive, sata 2 = unknown (have nothing attached for that drive so not concerned there)...  Noticed when I restarted this morning instead of trying to boot to the hdd it tried looking for mac ip addresses to boot so I had to restart again, it will always say " Drive not found then list the sata drives it cannot find but after pressing the F1 key it boots to my normal windows logon, not sure how to run the diagnostics for hardware outside of windows.

0 Kudos
8 Krypton

RE: post boot error message

Looks like you have 2 issues here.

First, open BIOS setup (page 10) - reboot and immediately press F2. Look for the SATA 0 through SATA n option in BIOS setup. Select SATA2 and DISABLE it. That should stop the error message at boot. Since the port is enabled, BIOS is looking for a drive there  but not finding it, and that causes the error message.

Second, why is your 1T HDD connected to SATA1? I presume that's the boot drive with Windows on it. The boot hard drive should be connected to SATA0. So it seems -to me- that you should swap the SATA data cables between the HDD and the DVD-RW.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
rednosedpits
6 Indium

RE: post boot error message

The hdd that came with the refurb system had issues with bad sectors and booting issues, so a new hdd was installed, but I did not change any of the settings in bios I may have connected the wrong electrical cords to the hdd and dvdrw drives when installing them in the system.

I just changed the sata cords now in bios sata 0 reads as the hdd and sata 1 reads as the dvdrw drive, I disabled sata 2 as recommended and still received drive not found but this time it changed to the sata 1 drive, could I have the boot sequence incorrect, I need to maintain the sata 1 drive as the first bootup drive.
for the sata operation options in bios it is listed on the raid auto detect/ata instead of the raid auto detect ahci, when attempting to change them from ata to ahci it tries to boot using the mac addresses or network that is not available so I changed it back.
I ran the preboot system assesment build 4521 it found no problems or issues, and also ran from within windows the dell diagnostics on the system it found no issues so not sure what is the next step. I am still pressing the F1 key to boot into windows...

0 Kudos
8 Krypton

RE: post boot error message

What version of Windows are you running?

If this is XP, and you didn't install SATA drivers early in the XP installation process by pressing F6, that would explain why you can only use RAID AutoDetect/ATA. You'd have to do another clean XP install with SATA drivers in order to use RAID AutoDetect/AHCI.

If the Integrated NIC option in BIOS setup is set to On w/PXE, or if network boot is in your boot sequence, that would cause the PC to try to boot from a network. The Integrated NIC option should be set to ON (but not w/PXE).

Have you checked the boot sequence to make sure the HDD (connected to SATA0) is first in the boot sequence? And be sure to disable the Onboard Network Controller in the boot sequence too.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
rednosedpits
6 Indium

RE: post boot error message

I currently am running windows 10 32 bit, as I said previously the original hdd that came with the computer crashed and I had to replace it, I replaced the 500 gb hdd with a wd 1 tb drive, installed windows 7 and then upgraded to windows 10. This morning in bios I reset to factory default, the system configured itself and tried to boot into windows, it had issues so I kept moving the boot devices around until it booted and gave me the option to repair windows using system restore, in bios now it shows sata 0 being the wd hdd, sata 1 registers as the liteon dvdrw drive but still when doing the post it says sata 1 not found I simply continue to press f1 to get back into windows.

0 Kudos
8 Krypton

RE: post boot error message

Dell doesn't support this PC model for Win 10, so did you find the right drivers and install them? And it's possible BIOS A22 has an issue with Win 10...

Go to the Intel site and use its wizard to scan your system for drivers and see if it offers an updated chipset, etc.

If the DVD is listed in the boot sequence, try disabling it there. But don't disable SATA1 because that will turn off the drive completely.

Is there something funky about the motherboard in this PC or maybe with the DVD drive?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
rednosedpits
6 Indium

RE: post boot error message

I downloaded the intel update utility and installed it, ran it and the only item it found was for the chipset so I had it upgrade that item. I checked in the bios and in the boot sequence removed the atapi liteon dvdrw drive as suggested but did not disable the sata 1 I am still receiving the same message that I have to press f1 to continue into windows the motherboard that came with this refurbished system is the Dell 0DR845 it seems to have worked wonderfully until I had to do the swap of the old cd drive for the liteon, I have been unable even from the liteon website to find any drivers for this dvdrw drive, it would have made it nicer if they had included a cd with the drive. I thought this was going to be an easy fix but it seems to drag on and at this time unless you have any further suggestions I am just going to be pressing the F1 key to boot into windows since all other suggestions so far have not resolved the issue.

0 Kudos
8 Krypton

RE: post boot error message

Drivers for optical drives are native to Windows.

If you pull this drive out and put the original back in, do you still have the problem? 

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos