Dell ST2420L Power Saving Mode

I am having problems with the ST2420L entering power saving mode when starting my computer or waking my computer up from sleep mode. Sometimes it wakes and starts normally, most times it fails completely.

The only temporary solution I got is if I unplug the monitor from my video card and replug it back in. This method doesn't work 100% of the time, I would have to do it 10+ or 20+ times to get it to finally display. After that, the resolution would be unchangable to 1920x1080, from then I would continue unplugging and replugging, until it finally detects my desktop resolution is 1920x1080.

I am already up to date with video drivers and monitor drivers.

I am connecting my monitor to my video card using hdmi with a dvi to hdmi dongle, because my video card does not have an hdmi slot.

Any ideas why this problem exists? And how do I fix it?

0 Kudos
2 Replies

Re: Dell ST2420L Power Saving Mode

Best guess is the convoluted converter connection is causing the problem.  

Best option, since you have a DVI port is to get the recommended DVI cable.  Dell, says use the "white optional DVI cable", but I would think any DVI cable would work.

I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives.  Studio One 3 Recordng Studio Software.

Dell SE2717HR 27" Monitor


Member of Nashville based R.O.P.E.

0 Kudos
PG from Oz

Re: Dell ST2420L Power Saving Mode

Hi there,

My issue with the Dell ST2420L monitor which I'm connecting to my Asus notebook via HDMI micro converter is that the both devices acknowledge they're connected with the notebook making the connection sound and the monitor going to "Power Save Mode" (when I connect to the notebook) and acknowledging "No HDMI Cable" (when I disconnect. I have all the latest drivers, tried to force connect via Control Panel - Display, also through the Intel Graphics and Media Control Panel and no matter how many times I disconnect / reconnect there is no image.....just a blank screen. It has worked in the past but always been flakey.

Can anyone recommed anything???


0 Kudos