Dell XPS 8100 - AHCI Port 0 Device Error

I purchased a Dell XPS 8100 - Manufactured on 2010-Aug-03.

Gave the subject message. Tried to follow the advise provided related to similar topics. Did not work or I am not technically savvy.

I had used several different PC Brands and never had a crash. Did not expect a Dell product to fail such as this. It is my mistake that I had not backed up any data. Do not have a extended Dell warranty/service plan and could not find a Dell Contact in Canada to get advise or send an E-mail.


Before I take it to a PC repair shop appreciate any advise.


What I want to know is: 

  1. If this is a full system crash or is it only limited to the HD?
  2. Can I at least recover the data
  3. Then re-format or put in a new HD and install new Windows.
  4. Can I recover the data on my own or need to get professional help


Thanks in advance for your kind advise.

0 Kudos
5 Replies

Re: Dell XPS 8100 - AHCI Port 0 Device Error

Hi Chris,

Please run diagnostics on the system to confirm hardware functionality. Here are the steps:

  • Restart the system and immediately start tapping the 'F12' key to enter the 'Boot Menu'.
  • Use the 'Down Arrow' key to highlight the 'Diagnostics' option. Press the 'Enter' key.
  • The diagnostics will begin. Please note the exact error message/code, if any appears on the screen.

If there is no hardware failure detected, then possibly the Windows has crashed and needs to be reinstalled.

You can recover data from the hard drive, for this you can purchase a hard drive enclosure and connect the Dell XPS 8100 to it. Then connect the enclosure to another system and backup the data. You may refer to Service Manual of this system for removing and reseating the components. Please follow the safety instructions before replacing the components.

If you are not comfortable doing this, then I suggest that you take assistance of a professional to back the data. Hope this helps.

Please reply back with the test results.

Thanks & Regards
Saharsh K
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USA; India. For helpful Dell Support Videos, you may click Here.
0 Kudos

Re: Dell XPS 8100 - AHCI Port 0 Device Error

Hi Saharsh,

Thanks for the advice. I did not get a chance to follow through your directions, until yesterday.  When I ran the diagnostics and further steps, following messages came up:

Error Code: 0146

MSG: Error Code 2000-0146

MSG Hard Drive 0 – Self testing log contains previous errors

Given code error code and messages can be  used by Dell Technicians …….

Continue: Pressed Yes

On Blue Screen:

Test Memory: Mp Memory Ver 0494 – Passed All

Test System: Pressed Yes:


Test: Confidence Test

Error Code 0F00:1332

MSG:  Disk Block 210482: IRQ did not set on time

Continue: Yes

Error Code 0F00:1332

MSG:  Disk Block 23167488: IRQ did not set on time

Ran overnight and it froze

Test Progress: 1%

Overall Progress: 80%

Does this means that the HD is beyond recovery?

Is it worthwhile to buy a “2.5 SATA to USB Adapter” to check and see whether I can recover some of the data files.

0 Kudos

Re: Dell XPS 8100 - AHCI Port 0 Device Error

Hi Chris,

Yes, you definitely need to replace that drive. Believe me, hard drives fail often, which is why we strongly recommend you have a data backup strategy.

You'll need a hard drive enclosure for a 3.5" drive in order to get the data files.

0 Kudos

Re: Dell XPS 8100 - AHCI Port 0 Device Error

I used a HD enclosure to read the problem HD by connecting to another PC. When trying copy the files of the user locations the following message came up. "You'll need to provide administer permission to copy the folder" As this is not the original PC how do I get round this? Is there a Dell utility software I can use the extract files? Any advise is greatly appreciated.
0 Kudos

Re: Dell XPS 8100 - AHCI Port 0 Device Error


Google "take ownership Windows 7", and you'll find the information you need.

0 Kudos