Highlighted
ABN555
Bronze

Inspiron 545/6 won't boot with TV connected to HDMI port

Similar problem I believe that the 540 users are experiencing in thread
http://en.community.dell.com/forums/p/19272741/19529273.aspx

Problem with the 545 is that with the monitor connected to either the DVI or VGA port AND a TV connected via the HDMI port the PC will not bootup. Even the laser in mouse does not turn on.

You have to physically remove the HDMI connector in order for the PC to bootup.

Plug the HDMI cable in after bootup as works fine even when coming out of sleep mode so is a reboot / cold boot problem.

Have tried flashing the BIOS from version A05 to A06 but made no difference. Seems that the flashing programme will not allow you to flash the BIOS with an older  version so have not tried going backwards.

Can’t try NVIDIA as suggested in the 540 thread as the 545s don’t have the required power plugs on the power supply.

Possible workaround that I haven’t personally been able to try is running the monitor via the VGA and TV via DVI-I port using a DVI-I to HDMI converter.

Other problem that I need to sort is disabling the auto switching off the TV , if its on normal TV channels, to the HDMI channel every time the PC is switched on or comes out of sleep mode. Any suggestions how to resolve that issue as well would be appreciated.

Tags (1)
0 Kudos
14 Replies
dhanrajc
Bronze

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

Hi,

This problem is solved by downgrading the BIOS version. The file is at dell site.

Following is the correct way downgrade the bios.

Create a DRMK boot Key  and put 530_1016_DRMK.zip on it.Boot Inspiron 530 from the USB key using F12 boot menu.  Unzip 530_1016_DRMK.zip and run : AFU877.exe 530_1016.bin  /sn/py/r .

Regards,

~ Ratz

0 Kudos
JJinVista
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

I'm having the same problem on my Inspiron 546.  It came with an integrated Radeon HD 3200 video adaptor - one SVGA port, and one HDMI.

By the way, this is a separate issue, but the two ports are so close together on the back of the cabinet, I had to shave the plastic housing on my SVGA connector so it and the HDMI would both plug in at the same time.  I don't see how Dell could have ever tested the HDMI port with the SVGA unless they did the same.

With an HDMI cable plugged in, it won't even get to POST.  The cursor flashes for 1 second (appearing on both the monitor and HDTV), there's 1 beep, the power button stays lit, and it hangs.    It doesn't matter whether or not the SVGA video cable is plugged in - the results are the same.

Unplug the HDMI cable, reboot, plug the HDMI cable back in after booting - everything runs fine.

My BIOS was shipped with version A05.  Dell Support said there was no way to downgrade to a previous BIOS version; the MoBo was the problem.  They sent a tech who installed a new one which happened to have version A04 BIOS.  Same problem.

I've been unable to get Dell to acknowledge that there has been a history of this type of problem extending across the 540s, 545, and 546 models, and they won't say whether or not they're working on a solution.

Dell washed it's hands of the problem by blaming it on my cable.  Said I had to buy a "Dell" cable.  The Dell website carries about a half-dozen brands of HDMI cable, but no "Dell" brand.

As far as I can see, my cable works fine - great color, no pixelization, no artifacts.  It's a High Speed HDMI 1.3a Category 2 certified cable.

My workaround - I'm buying an A/B switch for my HDMI that I'll leave connected in 1 path, and an empty connection on the 2nd.  When I need to reboot, I'll have to remember to temporarily switch to the empty connection.  I haven't tried this yet - I'll post again with the results.

Tags (1)
0 Kudos
JJinVista
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

Workaround!

My $15 HDMI A/B switch does the job.  I hook up my HDMI on one input, and a null input on the other.  Boot up with the null input, then switch over to the HDMI connection anytime after I see the Dell logo splash screen.

It's a dumb fix,   but it saves having to crawl under my desk to plug and unplug cables!

Tags (1)
0 Kudos
House Fan
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

Same problem!

Attached DVI - HDMI and no picture, PC Hangs on boot up. Attached original cables and it works fine.

I hate that DVI - VGA adaptor they send so you can use a VGA - VGA cable. Whats the point of them using DVI Graphics Cards if the PC won't even boot up when you attach a DVI - HDMI cable.

As always Dell sound plenty helpful in there answers as someone else has pointed out. (Sarcasum). Anyway thanks for posting guys, maybe one day they will fix this problem. (Doubtful)!!

0 Kudos
BrianMelton
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

Same problem here guys,

Dell has really been dropping the ball recently on their products. I ordered this 546 for the ONLY reason of hooking it to a TV at a HTPC. I cannot believe all I've been through to get this computer, than  I receive it and the thing does this? Dell really needs to speak up on this matter and give us an ETA of when this issue will be resolved.

0 Kudos
gs15
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

anyone ever get a solution to the hdmi issues other than disconnecting wire or changing video card?
not sure how they can make a product that has so many wide spread isues.
i'm new to this, will they come up with a download or program that will reolve the isse?

0 Kudos
House Fan
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

Hey,

In response to your question, to which I had the same issue, I updated the Bios to the latest version from the Dell Support Website and hey presto it worked perfectly.

I use a Dell Studio 540 and upgraded the to Dell Bios 1.1.3

Hope this helps.

 

0 Kudos
gs15
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

can you use both HDMI and VGA at same time?

0 Kudos
House Fan
Copper

Re: Inspiron 545/6 won't boot with TV connected to HDMI port

I only use DVI (PC) - HMDI (TV) and that works fine with upgrade of BIOS. Before I upgraded I had to use VGA - VGA, it;s all that would work.

 

 

0 Kudos