Only 10mbps on Optiplex 755 Intel® 82566DM 2 gigabit...help!!!

Hi all,

I formatted and installed Win7 on a 755 Desktop. My modem lights were staying Orange when connected to the NIC (LAN) so i presumed it was a driver issue. I have now installed Win XP HE.  I then ran the system scan from Dell and updated any drivers it required one of which was the LAN Drivers. I entered all the static IP settings and connected to my modem.

I am still getting the orange light on my modem/router which means only 10mbps, this is confirmed via the properties screen for my network connection which says connected at 10mbps. I tried various cat 5 cables and different ports on the router. I connected it to my other pc which has a 10/100 tplink card and it works fine. I checked the lights on the NIC and they are green. 

Also when i power off the PC my routers port light stays on and orange as if the NIC is still powered. On other PC's connected the light powers of when unplugged or the pc is off. I have tried resetting defaults in the BIOS incase the previous company had some weird settings. I also tried to set the Duplex and Speed manually from advanced settings. I dont understand all the settings such as 10, 100, 1000, full and half etc but when i selected say 100 full or half the light on the modem turned green so connected at 100 but then the pc lost connection. The light stays on but the pc says unable to connect to network. 

How on earth do i fix this issue, am i missing a driver or whats going on?

0 Kudos
2 Replies

Re: Only 10mbps on Optiplex 755 Intel® 82566DM 2 gigabit...help!!!

The Networking section of the forum  HERE would be the most appropriate for your problem

I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives.  Studio One 3 Recordng Studio Software.

Dell SE2717HR 27" Monitor


Member of Nashville based R.O.P.E.

0 Kudos

Re: Only 10mbps on Optiplex 755 Intel® 82566DM 2 gigabit...help!!!

Did you install the chipset driver as the very first driver loaded after installing XP HE? Without the chipset driver the NIC driver might not install or not install correctly.

You didn't say if you have the Broadcom or Intel NIC but there's an "urgent" update for the Intel 825xx listed for the Optiplex 755.

Are you sure this is a PC problem? Sounds -to me- like it's a modem/router probelm. Have you tried resetting the modem and router by powering off, waiting a few and powering them on again?



Forum Member since 2004
I am not a Dell employee

0 Kudos