Highlighted
caffewmilk
Bronze

USB ports stop working after waking from sleep mode

Jump to solution

Hi,

My system is a Dell Optiplex 790, DT box style. It's running Windows 7 64bit with all the latest service packs, patches, drivers, etc.

To save time, I started using 'sleep mode' a few months back.  I'm happy with being able to bring up the computer by just clicking the mouse.

Well, if I have the mouse and keyboard plugged into any of the rear USB ports, both peripherals stop working a while after the computer wakes from 'sleep mode'.

I found a few workarounds and fixes *** back to the Vista days and some for 7 but they didn't make a difference.  All the while, the front USB ports work fine.

Could this be a possible motherboard issue?

Thank you.

0 Kudos
9 Replies
RoHe
Diamond

Re: USB ports stop working after waking from sleep mode

Jump to solution

Have you tried changing the settings for C States Control and Deep Sleep Control in BIOS Setup?

And have you changed the setting on Power Management tab for each USB root hub in Device Manager by unchecking the box "Allow PC to turn of this device..."?

 

Ron

Forum Member since 2004
I am not a Dell employee

caffewmilk
Bronze

Re: USB ports stop working after waking from sleep mode

Jump to solution

Hi Ron.  Yes, 'Allow PC to turn on...' setting is done for all the USB root hubs.  After reading your tip, I disabled 'C-States Control' and 'Deep Sleep Control' in the BIOS.  I'm going to give it a run and reply back on what happens.

Thanks.

0 Kudos

Re: USB ports stop working after waking from sleep mode

Jump to solution

Hi caffewmilk,

I am sorry about this; in addition to what RoHe suggested please uninstall each and every USB root hub in device manager

Start > in search box type in device manager > under the universal serial bus controller> select the each and every USB root hub right click on it and click on uninstall. Restart the computer and check if the USB port works?

Thanks and regards,
Senthil S
#iworkfordell.
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US / India . For Dell support videos click here.

0 Kudos
RoHe
Diamond

Re: USB ports stop working after waking from sleep mode

Jump to solution

'Allow PC to turn on...'

Allow PC to turn off....  should be unchecked.

 

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
caffewmilk
Bronze

Re: USB ports stop working after waking from sleep mode

Jump to solution

Ok, guys.  Before starting this thread, I had already done the "Allow PC to turn off..." setting on all the USB root hubs a few weeks back.  The issue was still there.  So far after disabling 'C States Control' and 'Deep Sleep Control', the issue has not come back.

I'd like to give it another day, though, before I mark my question answered.

Thank you Ron!

0 Kudos
RoHe
Diamond

Re: USB ports stop working after waking from sleep mode

Jump to solution

If that solves the problem and you've got nothing better to do, you can re-enable C States and Deep Sleep, one at a time to see which one of them causes the problem, and then leave the other one enabled to save a bit of energy.

Please post back and let us know how it goes...

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
caffewmilk
Bronze

Re: USB ports stop working after waking from sleep mode

Jump to solution

Deep Sleep was the culprit.  C-States is OK to leave on.  Thank you.

0 Kudos
RoHe
Diamond

Re: USB ports stop working after waking from sleep mode

Jump to solution

Thanks for the feedback. That should help others who have this problem. Glad we were able fix the problem!

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
TomIT
Copper

RE: USB ports stop working after waking from sleep mode

Jump to solution

I am currently working with Dell machines in a Windows 8 Environment and have found that a setting in power options stops the USB devices from reconnecting after coming out of sleep mode. In control panel go to 

"power options\change plan settings\change advanced power settings\sleep\allow hybrid sleep\"

Turn allow hybrid sleep to "OFF" and then click ok to exit and this fixed my issue. It may not fix USB issues for every sleep scenario but is worth a try as it worked for me.

Thanks

0 Kudos