2 Bronze

ECS 2.0: Installation OK; but, Can't access admin url via 443

Hey everyone,

New to ECS --- but installing ECS2.0 Single note on a VM --- with the suggested requirements.   The install script runs successfully, apparently --- however, I cannot access the admin URL via 443.

Seems like the web server supporting that site isn't up and running.

Please see attached screenshot --- The install script was run as such: 

# sudo python step1_ecs_singlenode_install.py --disk sdb sdc

*I have NOT ran step2 yet --- as per instructions

Any help would be appreciated!

Thanks,

Will

wsellers@venyu.com --- or ---- wsellers@gmail.com

0 Kudos
13 Replies
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Hi,

Could you please help verify if the docker container is still running. You can do this by executing "docker ps" on the command prompt.


Thanks

Dharmesh

0 Kudos
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Just got back to my desk..... trying this now...

0 Kudos
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

EMC-ECS-DockerInfo.pngThakkd,

Ahhhh Sooooo, it looks like docker is a bit screwed up...See attachment.  It looks like I don't have any containers --- but the service is running.... Was the "step1" install script supposed to create a default container?  I didn't see any errors from the install script..... any thoughts?

0 Kudos
Anonymous
Not applicable

Re: Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

If the container was started, and then stopped there should be log files in /var/log/vipr/emcvipr-object that you can check for errors.
.  Check whether the container was run by executing "docker ps -a", this should show any running or stopped docker containers.

If the container was started and stopped, please provide the logs so we can review them.

If the container was never started, I'm not sure if you can just run the first script again, as it is not clear to me whether it is idempotent.

Thank you,

John

0 Kudos
3 Argentum

Re: Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Doctor Lund!  There has to be some kind of special ECN badge for the first ever use of the word 'idempotent' on the site!

Congrats! 

Mike Horgan

0 Kudos
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Right so it seems that for some reason the step 1 did not actually complete successfully and the docker container was not executed at all. In other words, the service is not running and hence cannot be accessed. Could you retry in a clean environment and attach a log file with all the output on the screen so that we can see what is going on. Also, please let us know what environment are you trying this on, vCenter vs AWS vs. Azure.

Thanks

Dharmesh

0 Kudos
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Hi Will,

Did you get a chance to try running the first script again. If you are running into the same issue in a clean install could you please send us the docker container logs as John indicated.

Thanks

Dharmesh

0 Kudos
2 Bronze

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

Hi Will,

I was encountering the same issue with accessing the web gui on tcp/443 on the running instance. My host OS is CentOS 7 and once I disabled the firewall (systemctl stop firewalld.service), I was able to get to the gui and all of the API ports. You can make the firewall change permanent if desired (systemctl disable firewalld.service).

Cheers!

Michael

0 Kudos
Anonymous
Not applicable

Re: ECS 2.0: Installation OK; but, Can't access admin url via 443

from host-and-container-configuration  step 6

Please confirm "how" you are trying to access the admin GUI.

In the images provided it appears you are attempting to connect to the Admin GUI using telnet.

It may not be clear from the documentation but it is implied that you should be using a web browser (preferably a modern one like Chrome/Firefox/etc) in the instructions :  "For example: https://ecs-node-ip-address"

0 Kudos