Highlighted
Mgamerz
Copper

Dell Command Update CLI - System automatically restarts without using /reboot

I am using dell command update's CLI in a system setup script. I install a bunch of software, drivers and windows updates and then do a restart at the end of the script to flush all of it through. The documentation for DCU CLI states that if a reboot is required, it won't restart on its own UNLESS the /reboot option is specified.

I have been going through *** trying to find someone at dell pro support to actually tell me why my system restarts. Nobody there seems to actually want to try to fix the issue, only to tell me "that sometimes when a driver is installed it needs to restart". No duh. The GUI doesn't force a restart unless I tell it to. The CLI is no different. Nobody there understands it and at this point I think they aren't going to even contact engineering to see if this is a bug (I never get any emails from them on this ticket unless Is specifically ask them).

Is this a bug? This kind of kills my script. Due to bugs in dell drivers (not installing if .net 4.6 is installed) and our software (which requires .net 4.6) this makes me manually do this, which for like 75 systems is a pain.

0 Kudos
3 Replies
CMDaniel
Copper

RE: Dell Command Update CLI - System automatically restarts without using /reboot

Hi,

Do you have any updates on this? I'am currently running into the same issue. While deploying a E7440 with the CLI tool my script is failing after the reboot. There should be no restart in silent mode.. I think it should be one of these packages:

Network_Driver_48WF6_WN32_18.33.0.2_A19.EXE -> reboot required

Chipset_Driver_GH5T3_WN32_10.1.1.18_A04_01.EXE -> reboot required

Network_Driver_K59N9_WN32_19.0.1603.630_A12.EXE -> running update and no more log input

Update_K59N9.log shows up an ERROR:


MUP started: Wed Nov 30 17:36:27 2016

Command Line: C:\ProgramData\Dell\drivers\Network_Driver_K59N9_WN32_19.0.1603.630_A12\mup.exe /qn /l:C:\ProgramData\dell\drivers\Network_Driver_K59N9_WN32_19.0.1603.630_A12\DUP194A.tmp
****************************************
MUP Package contains version: 19.0.1603.0650
Execute: setup.exe   /qn
Error: setup.exe exited with return code: 1641
MUP finished: Wed Nov 30 17:36:41 2016

Exiting with Return Code: 1641

[11/30/16 17:36:41]    
--- End of Vendor Software Log ---

[11/30/16 17:36:41]    Vendor Software Return Code: 1641
[11/30/16 17:36:41]    Name of Exit Code: ERROR
[11/30/16 17:36:41]    Exit Code set to: 1 (0x1)
[11/30/16 17:36:41]    Result: FAILURE
[11/30/16 17:36:41]    Name of Exit Code: ERROR
[11/30/16 17:36:41]    Execution terminated at date-time 11/30/16 17:36:41
[11/30/16 17:36:41]    ######


Any ideas?

0 Kudos
Trussell34
Copper

RE: Dell Command Update CLI - System automatically restarts without using /reboot

Were either of you able to get any answers on this? I'm trying to solve a similar issue and struggling to get any traction from Dell as well. 

Also, what does your script look like that you're using? I'd love to compare notes. 

Thanks

0 Kudos
Mgamerz
Copper

RE: Dell Command Update CLI - System automatically restarts without using /reboot

Nope. Dell claims they support this tool but there seems to be literally no way to contact anyone who can get answers or submit actual (listened to) feedback on the application. I was transferred from pro support to "someone who could help" (via email), but they unsurprisingly never responded.

0 Kudos