fuzzdude
Bronze

E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Hi all,

Just wonder if anyone else is having issues with Windows installation crashing with the Intel Management Engine Drivers injected directly in to the WIM Image?

The error message that pops up during the installation says "Windows could not configure one or more system components. To install Windows, restart the computer and the restart the installation". Once rebooted it will loops with the message " The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows click OK to restart the computer, and then restart the installation"  I've check the logs in X:\$WINDOWS.~BT\Sources\Panther\, but can't find any thing useful (or understand).

I can get installation to complete by excluding the the IME drivers, but this leaves the device with no drivers in the Device manager. The same drivers can be installed manually with out any issues after Windows has finished installing. 

The driver revision for the 7 series latitudes I am using is A00 released on 09/06/2013.


0 Kudos
30 Replies
Caf83
Copper

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

I'm having the same problem with OSD to an E7440 but without the drivers in the WIM image. I use an Auto Apply Drivers task to install PnP drivers during the task sequence and it's failing during the first boot initialization with the same error you are seeing.

I'm unable to access logs at that point though. How were you able to narrow down the problem to those specific drivers?

0 Kudos
Caf83
Copper

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

I disabled the drivers which you suggested and still have the same problem during the "Setup is applying system settings" step.

0 Kudos
fuzzdude
Bronze

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Hi Caf83,

With your first post, I just added one driver at a time (from the chipset folder) and re-deploy, took forever and it had to be the last driver that was failing on me.

For your second post, I have also find, that the on E7440 laptops , the drivers for the 'ST Microelectronics Free Fall Sensor' device kills my windows installation as well as the IME drivers. The drivers for this are located in the folder E7440\win7\x86\chipset\08V18_A00-00\ in the CAB file.

By the way, I'm deploying Windows 7 Enterprise 32bit, using Lite touch via WDS  on USB or PXE.

I'll probably call DELL pro support to see if they help. I'll keep you posted if I get any where.

0 Kudos
Highlighted

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Some of the Windows 7 drivers for the new Dell systems may require an update of the KMDF to version 1.11.  The KMDF is a component of the OS and the update is available from Microsoft at the link below.  The usual treatment is to include the KMDF update into your base image until it is rolled up into a service pack.  Some of you may remember seeing this issue with XP/Vista when Win7 came on the scene.

 

Symptoms that a KMDF update is needed for a Windows 7 driver:

 1.       Yellow bang in device manager for components that you know you have a driver available

2.       Black screen during OS deployment

 

http://www.microsoft.com/en-my/download/details.aspx?id=38423

 

Please post back if this helps address the issues you are seeing.

fuzzdude
Bronze

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Thanks Warren.

I'm not experiencing those symptoms and drivers work post windows installation. But I'll inject the update to the wim file and give a go Smiley Happy

 

 

0 Kudos

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Adding the KMDF update is best practice as it may pop-up in other areas later or until it gets pulled up in a service pack.  Best to get it out of the way now.  let me know if the ME driver is still problematic afterwards.

0 Kudos
Caf83
Copper

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

It was a combination of the IME and the Accelerometer. Deployment was successful after I disabled both drivers. I decided to install them both later in the TS as a regular software install.

I downloaded the full driver package for each one, created silent installations and they tested fine in the OS. When I tried to run the IME install in the task sequence it installed the drivers successfully but exited with this error:

Failed to run the action: Install Intel Management Engine Driver.
Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows)

I was able to reboot into the OS and the drivers are installed and working properly. For now I just changed that task to continue on error.

I'm schedule to create a new core image next week so I'll make sure the KMDF is part of it and then retest the PnP installation and update this if it fixes the problem.

0 Kudos
fuzzdude
Bronze

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Hi Warren,

I added the KMDF update to my .wim via dism and all drivers installed successfully during the OS installation.

Thanks for your help.

 

0 Kudos
fuzzdude
Bronze

RE: E7240/E7440 - Intel Management Engine Drivers crashes Windows 7 setup

Jump to solution

Hi Warren,

I added the KMDF update to my .wim via dism and all drivers installed successfully during the OS installation.

Thanks for your help.

0 Kudos