RE: E7450 SCCM Build

Jump to solution

Oops apparently the screenshot i pasted didn't appear in the post.. here let me type the files names..


e1c6...

e1d6...

e1r6..


So basically see if you have a few files starting with e1...

0 Kudos
alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution

And to everyone who does manage to PXE boot and get an IP address, how far are you getting when importing the Dell CAB file?

We have spent weeks downloading, importing and testing individual drivers, have had to leave out multiple drivers to not get an error when building and are now left with 2 dirty drivers - but an almost SCCM built 7450!

0 Kudos

RE: E7450 SCCM Build

Jump to solution

Alex_1984,


In all the 3 pages, I see, only you have mentioned about different drivers failing. That includes chipset as I see in one of your threads. Can you help us understand how you determined chipset driver failed.

What is the error you are seeing in chipset case?

Can you also please run the command I have given and provide the results here. That will help us narrow down to the root cause.

I can understand this issue has consumed much of your time, apologize for that and really appreciate your efforts here.


-Sreejith.

0 Kudos
Highlighted
alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution

Hi Sreejith,


Maybe no-one has got as far as importing the CAB drivers?

When including certain Intel & ST Microelectronics drivers we see the following error.
 
www.danielclasson.com/sccm-osd-issue-kernel-mode-driver-framework
www.danielclasson.com/.../error.jpg

We then removed and added the drivers manually until we got to the driver(s) causing the error

We are now in a position where we have just 2 dirty drivers left - Broadcom NFP and PCI Simple communications controller.

Thanks

0 Kudos

RE: E7450 SCCM Build

Jump to solution

Thanks a lot for the prompt response. So as you have pointed out the KB explains how  you can inject the necessary framework into your OS image. Some of these drivers are built with a framework version that your existing OS doesn't support inbox. So you will have to inject them. This is also stated in our driver cab FAQ. Please refer below link...

en.community.dell.com/.../8031.dell-command-deploy-faq

So I understand you have already fixed the framework related issues. I do not understand the last statement made - left with only Broadcom NFP and PCI... if the framework issues are resolved then you should be able to install the rest from the driver cab. Are you saying there are two more yellow bangs shown in your device manager?

0 Kudos
alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution

Correct.  We have the correct framework drivers.  

However importing drivers such as the Intel thermal framework drivers causes the same error message.  If then breaking them down and removing the thermal framework manager driver then it builds properly.

The ST microelectronics Windows 8 drivers also caused the same issue.

Yes, two more yellow bangs.  Wifi and Dell control vault.  We are creating packages and programs for these dirty drivers pointing to the correct needed MSI's

0 Kudos
frankmyl
1 Copper

RE: E7450 SCCM Build

Jump to solution

We are having the same issue however even after we disabled the thermal and microelectric drivers are still getting the "Windows could not configure one or more system components" error.  

This is frustrating that you EOL the 7440 and have a poorly tested replacement as the alternative.  

0 Kudos
wzsmith
1 Nickel

RE: E7450 SCCM Build

Jump to solution

Same frustrations here, Frank.

We deploy with SCCM and the best solution that I've come up with is to add the driver packages as Applications in SCCM, then wrote some powershell to detect the presence of the hardware with drivers that do not import properly and need to be installed after the OS is on the PC. The script queries Win32_PNPEntity via WMI looking for hardware IDs and then adds a Task Sequence Variable that we use in an Install Applications task to get the drivers installed. Convoluted as all get out, but there's not much else we can do.

So far, I've had to add the drivers you mentioned for the 7550, a couple of WiFi/Bluetooth cards, and the AMD R5-240 video card that ships with some Optiplex desktops. 

To top it off, the BIOS is also buggy and causes problems with our full disk encryption software. (Link

0 Kudos
wzsmith
1 Nickel

RE: E7450 SCCM Build

Jump to solution

JT, for what it's worth, I was able to get things working when using USB media to boot but no luck with PXE for some reason. I'm not sure what the difference between the two would be.

0 Kudos
VVV2015
1 Copper

RE: E7450 SCCM Build

Jump to solution

So we are 4 pages in and a month further... Dell, any suggestions?