alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution


frankmyl - You cannot simply disable them once they are imported unfortunately.  We tried this and it didn't work (got the same error when they were disabled) 

If they were not imported at all though, then it does work.  This is what made it more difficult sieving through drivers - We broke Intel drivers down into 3 different folder names to make it easier.

Just about to kick off a build when dist points have updated to see if 2 packages in MDT database for dirty drivers are working too.

0 Kudos
nbot22
1 Copper

RE: E7450 SCCM Build

Jump to solution

It look like the driver for the i217-LM also works for the i218-LM. I obtained that driver from the Intel's website and added it to the packages I made for the E7240 and E7250. It worked for the 7240, I don't have a 2nd 7250 to test on. 

0 Kudos

RE: E7450 SCCM Build

Jump to solution

Alex,


Can you please do the "dir" I was asking about previously, in the WIN PE environment?. Let us focus on the network issue. We can look into other drivers later. They shouldn't fail ideally. Network as we see has been reported as having an issue, by a few here.

0 Kudos

RE: E7450 SCCM Build

Jump to solution

Hi VV2015,


We are trying our best to help. Here is one example. But there is some aberration since a lot of issues are being presented here. We are trying our best to do the RCA. The solution will definitely come in one of our subsequent releases of driver cab.

Solution for you guys, as helped by dell support:

1) Install Windows ADK (www.microsoft.com/.../details.aspx), selecting WinPE

2)Take the WinPE.wim file from the install directory (C:\Program Files (x86)\Windows Kits\8.1\Assessment and Deployment Kit\Windows Preinstallation Environment\amd64\en-us)  and place in an easy to remember directory

3)Download the drivers direct from intel (https://downloadcenter.intel.com/download/23073/Network-Adapter-Driver-for-Windows-Server-2012-R2) and run the installer.

4)Extract the network drivers from the temporary folder that is created. You are looking for the NDIS63 and 64 folders

5)Copy these drivers to an easy to remember location

6)Using DISM mount WinPE and import the network drivers from the driver location

7)Unmount the WinPE Wim image, and from there import into SCCM 2012

8)Apply the Image to the relevant task sequence and boot

0 Kudos
Highlighted
alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution

Hi Sreejith,

Yes - checking \filerepository shows multiple files starting with e1... e.g. e1c62x64.inf_amd64_neutral_08fa4873ba6284ba

Back on the winPE network issue - Has anyone tried updating with the latest HD controller and Network drivers as I suggested?

I217-LM v 12.12.50.4
Chipset SATA RAID controller - 13.2.0.1016
AHCI controller - 13.2.0.1016
Realtek USB GBE family controller - 7.11.716.2014

These all have a version date 06/14 and are from the WinPE 3.0 Driver Pack A15 

Thanks

0 Kudos
Brian42
1 Copper

RE: E7450 SCCM Build

Jump to solution

We evaluated a unit. We had to inject/import both the Windows 8 and Windows 7 drivers for the NIC, storage, etc - whatever devices didn't work. Because our version of WinPE was based on Windows 8 and we were deploying Windows 7.

alex_1984
1 Nickel

RE: E7450 SCCM Build

Jump to solution
Did you manage to inject all the Cab drivers and have a working build? We are using WinPE 3.0 deploying Windows 7 and had to exclude some Windows 8 drivers. Now have a working SCCM build but has taken a lot of messing around
0 Kudos

RE: E7450 SCCM Build

Jump to solution

Hi,

Meanwhile we have come up with updated Win PE cabs. This would fix a few issues. These are available at the location below.

en.community.dell.com/.../2065.dell-command-deploy-driver-packs-for-enterprise-client-os-deployment

We are working with Intel for the latest version and that also will be made available ASAP.


Alex - Thanks a lot for running the checks. We have noted the behavior and it will help us triage the issues.

blaughw
1 Copper

RE: E7450 SCCM Build

Jump to solution

This should do the trick, but also the NIC requires Windows 7 Kernel Mode Driver Framework be updated to 1.11, which is not the default framework for Win7.

This was the case on the E7440 as well.  I injected NIC drivers into my WIM, and then added the KMDF patch in the post-install, pre-first boot task sequence.

This is where I got hung up a year ago, but I had no issues transitioning from E7440 to E7450.

0 Kudos
Frater0
1 Nickel

RE: E7450 SCCM Build

Jump to solution

We need Win PE 5 (Windows 8.1 32bit nic drivers) for this model) Any suggestions? Dell tech support does not even know what PE is.. I mean really?

0 Kudos