Highlighted
peteostro
1 Nickel

MDT/SCCM E7440 Wifi driver not loading

Having a weird issue with the Latitude E7440. I added the drivers to MDT using the dell cab drivers for windows 7 x64

Windows 7 X64 OS installs fine but when I go to device manager there is no wifi module listed, and the OS does not see any wifi device. I checked the bios and it shows there is a wifi chip and made sure wifi is on in the bios and the wireless switch is on the correct position. Bluetooth is showing up in the device manager. Looking at MDT logs it sees the Wifi device and copies to driver down to the system, show it should install during windows setup but does not. If run the Dell Wireless 1601 WiFi/BT Driver (from dells web site) install it, it says there is not device. but then asks me to reboot. When i reboot the wifi device then shows up.

Not sure whats going on. I also used dism to install Windows 7 Kernel Mode Driver Framework 1.11 to make sure it was not something with the driver installer but that did not make a difference. 

0 Kudos
2 Replies
TJaiks
1 Copper

RE: MDT/SCCM E7440 Wifi driver not loading

We are seeing this now also with the latest batch of E7440s we just got.  Did not see this with the ones we got in January.  Any ideas?

0 Kudos
mdouglas_2014
1 Copper

RE: MDT/SCCM E7440 Wifi driver not loading

Hi. I have seen this with other dell drivers for other dell models. Traditionally what I did was create a silent install package taking defaults. Then add that package as an application. In the Custom Task area of MDT I would add "Install  Application" and add that software driver package I made. In the options of mdt I would add "all conditions are true" and add a WMI query that queries the PC and if this model exist then install this package. Mainly audio drivers for Latitude dell laptops I have had to do this on. Even though I have the inf file it wants to run the setup package to install correctly.


Mike

0 Kudos