Highlighted

New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

Hi there! First off, I had to update my Win PE 4.0 images in order to get an IP adress. That was the easy part. But when trying to apply Win7 x86 on a E7240, the OS get's applied, the driver cab gets applied.

After the first reboot, when the Windows 7 installation is "configuring itself", I get a "" which will get the machine stuck in a loop. I cannot get passed this. My first thoughts were; "there's something wrong with the driver package". So I tried to rebuild it with same results. I ended up installing the machine manually, and adding the drivers manually (from the same CAB). No errors at all.

Then I used the "ConfigMgr Driver Injector" for grabbing the drivers that were installed on the OS.

http://gallery.technet.microsoft.com/ConfigMgr-Driver-Injector-aae7d17d

With these, I built a new driver package which applies fine. The OS gets installed and all, but afterwards I have two missing drivers: A chipset driver. Unfortunately I cannot give the exact driver ID as these new models haven't arrived at us to a 100% yet. My only conclusion is this: we need a new CAB package as there obviously seems to be problems with the drivers in the current one. The same issues applies to the E7440 aswell, except I get an "unknown device" along with the chipset driver.

The x64 CAB package seems to work fine on the E7440!

When can we expect new driver CAB's ?

Tags (5)
0 Kudos
1 Solution

Accepted Solutions

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

Hi Johan, 

Please see Warren Byle's article on the new Kernel Management Driver Framework Update that is now required for many of the new Dell models (including the E7240/E7440) http://en.community.dell.com/techcenter/b/techcenter/archive/2013/10/07/kernel-mode-driver-framework...

I also have a linked article showing you exactly how to apply this update offline during your task sequence.

0 Kudos
5 Replies

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

Hi Johan, 

Please see Warren Byle's article on the new Kernel Management Driver Framework Update that is now required for many of the new Dell models (including the E7240/E7440) http://en.community.dell.com/techcenter/b/techcenter/archive/2013/10/07/kernel-mode-driver-framework...

I also have a linked article showing you exactly how to apply this update offline during your task sequence.

0 Kudos

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

This sounds like you need the KMDF 1.11 update.  Details can be found here -> http://en.community.dell.com/techcenter/b/techcenter/archive/2013/10/07/kernel-mode-driver-framework...

0 Kudos

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

Thanks Dustin!

But this puzzles me:
The x86 version of KB2685811 is already present in our win 7 x86 Wim file.

The x64 isn't of course...

any ideas?

0 Kudos

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

This is odd.

After applying the image, i manually tried to apply the kb, and it got installed. Eventhough SCCM said that the KB was already present.

I'm rebuilding my ref right now including the kb (i needed a new ref anyways), and will try again later on.

0 Kudos

RE: New Windows 7 x86 CAB's needed for E7240 and E7440

Jump to solution

Rebuilding the ref image solved the issue for me!

0 Kudos