1 Copper

Precision 5510 - No TPM option available in BIOS


I have a Precision 5510 which is Bitlocker/MBAM encrypted but for the past couple of days i've been getting the Recovery screen at each reboot.  After disablin the protector & trying to re-enable it, I get told that 'Compatible TPM cannot be found'.  I know there is a TPM on this as it has already been encrypted so what has happened??  I'm running Windows 10 (x64) & machine is fully patched & using the latest BIOS version (as of today, 26/1/2017).

I did have to perform a hard reboot earlier this week, could this be related?  I did see something online regarding hared reboot affecting Precision 5510 but the solution to reboot did not work for me.  I have also tried to reinstall the TPM driver but it won't appear in Device Manager nor is there an option in BIOS anymore to enable/activate TPM.

I'm at a loss, anyone know if there is a known issue with Precision 5510 losing TPM? 



0 Kudos
6 Replies
1 Copper

RE: Precision 5510 - No TPM option available in BIOS

Just wanted to tell you that i have the same issue since this morning .. Updated to the latest bios version... but still same issue...


0 Kudos
1 Copper

RE: Precision 5510 - No TPM option available in BIOS

Have the same issue today with one of our users.

0 Kudos
1 Copper

RE: Precision 5510 - No TPM option available in BIOS

Call support ... they replaced my mainbord... kr Kristof

0 Kudos
1 Copper

RE: Precision 5510 - No TPM option available in BIOS

This helped for me:

  1. Power off the laptop and remove any power adapters.
  2. Remove the rear cover (screws do not come out fully).
  3. Remove the SODIMM(s).
  4. Remove the M.2 drive
  5. Remove the battery (one screw, pull the tab to remove the battery connector from the board).
  6. Press and hold the power button for 20 seconds (to drain capacitors).
  7. Reinstall the SODIMM(s).
  8. Put the M.2 drive back in.
  9. Reconnect the battery and screw it down.
  10. Attach the rear cover.
  11. Power on the laptop

 After this TPM was available again in the BIOS.

Then I updated the TPM from 1.2 to 2.0. You can download the tool when you search for security drivers for Precision 5520 (Note: Dell doesn't provide it on the driver page for 5510, but it can be used for all Dell TPMs that support 2.0). There is also a quite good manual how to install it when using bitlocker (disable bitlocker, Disable Auto Provisioning, Clear TPM, etc.)

see also: en.community.dell.com/.../11850.how-to-change-tpm-modes-1-2-2-0

Tags (3)
0 Kudos
1 Copper

RE: Precision 5510 - No TPM option available in BIOS


TPM suddenly gone. I recently upgraded my bios and poof went tpm...

Replacing the motherboard feels like a huge overkill for what is likely a software/firmware issue.

Update, November 11th: I tried again shortly after and at that time TPM was again available to me. I was able to upgrade it to TPM 2.0 and it has been working normally since. It shows up in the BIOS setup, it shows up in tpm.msc and Bitlocker just works. I'm baffled and a bit upset I couldn't figure out why it suddenly started working again out of the blue.

0 Kudos
1 Copper

RE: Precision 5510 - No TPM option available in BIOS

I had the same issue, and here's how we fixed it:


  • When powering on, BitLocker is prompting for a Recovery Password, 
  • TPM is missing from BIOS Security settings


  1. Remove the screws from the bottom of the laptop. 
  2. slide and lift the bottom cover to remove. 
  3. Remove the battery and unplug
  4. Wait 30 seconds 
  5. Replace battery and put the cover back on, but do not put the screws in yet. 
  6. Carefully, supporting the bottom, flip it laptop over and try to power up. 
  7. Enter the BIOS and verify the TPM is present 
  8. If the TPM is still missing:
    1. Remove the cover agan
    2. Remove the battery again
    3. Remove the BIOS battery 
    4. Wait 30 seconds 
    5. Reinsert the BIOS battery
    6. Reinsert the battery
    7. Replace the cover and screws
    8. Verify TPM shows in BIOS
    9. If the TPM is still missing
      1. Purchase an HP Laptop

I hope this helps. 

0 Kudos