Highlighted
mikeniccum
1 Nickel

Unable to set embsataraid on newer BIOS version of the Optiplex 7040 using cctk

Jump to solution

I am using ConfigMgr 1606 with OSD to image Dell Optiplex 7040 with Windows 7 x64.  This has been working up until today.  The older machines had a BIOS version in the range of 1.4.5.  The machine today had a BIOS version of 1.5.4.  The below command is now failing.  I can break out to a command prompt with F8 and I can run cctk.cmd --embsataraid and retrieve the value.  If i run the command manually to set the embsataraid value it fails.  I tried setting it to ahci, raid another value I can't recall but they all failed with the same messages as below.  Is embsataraid still supported on newer BIOS versions on the 7040 SFF?

--Running command "x86_64"\cctk.exe --embsataraid=ahci --valsetuppwd=password

The option 'embsataraid' is not available or cannot be configured

Thanks,

Mike

0 Kudos
1 Solution

Accepted Solutions
mikeniccum
1 Nickel

RE: Unable to set embsataraid on newer BIOS version of the Optiplex 7040 using cctk

Jump to solution

Just happened to notice that literally today a new version of Dell Command Configure 3.2.0.209 came out.  I packaged up this new version and took it for a drive.  The intial testing failed as the HAPIInstall.cmd was renamed to InstallHAPI.bat and the cctk.cmd was renamed to cctkcmd.bat.  I couldn't make this stuff up.  After updating all the commandlines in the Task Sequence the first initial test succeeded.  In case I didn't mention it, I WAS previously using Dell Command Configure 3.1.0.0.

www.dell.com/.../DriversDetails

3 Replies
mikeniccum
1 Nickel

RE: Unable to set embsataraid on newer BIOS version of the Optiplex 7040 using cctk

Jump to solution

I also wanted to mention I set the BIOS manually and installed windows and I can run the Dell Command Configure utility and see the embsataraid property.  I can also go into the BIOS and set it manually to any setting I like.  I was also able to use cctk and set other values.

Thanks,

Mike

0 Kudos
mikeniccum
1 Nickel

RE: Unable to set embsataraid on newer BIOS version of the Optiplex 7040 using cctk

Jump to solution

Just happened to notice that literally today a new version of Dell Command Configure 3.2.0.209 came out.  I packaged up this new version and took it for a drive.  The intial testing failed as the HAPIInstall.cmd was renamed to InstallHAPI.bat and the cctk.cmd was renamed to cctkcmd.bat.  I couldn't make this stuff up.  After updating all the commandlines in the Task Sequence the first initial test succeeded.  In case I didn't mention it, I WAS previously using Dell Command Configure 3.1.0.0.

www.dell.com/.../DriversDetails

mikeniccum
1 Nickel

RE: Unable to set embsataraid on newer BIOS version of the Optiplex 7040 using cctk

Jump to solution

I love having a conversation with myself!

0 Kudos