Clint11
2 Iron

RE: cctk.exe --tpmactivation=activate does not work on any of my models

I have activated the TPM successfully on a D630 using CCTK. Some models require you enable the TPM, then reboot, then activate the TPM, and then reboot. I think the 630 is one of those. I do all mine like that though because the behavior is inconsistent across models.

0 Kudos
His Boy Elroy
1 Copper

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Has this issue been fixed?  I am having the exact same problem (I can turn on TPM, Activation says it succeeded but if I look at the BIOS it is de-activated).  I have E6400 and E6420 laptops I'm testing with, the problem is consistent with those two models.

0 Kudos
Clint11
2 Iron

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Are you running the latest BIOS version for each of those? Can you go through the exact steps that you do including any reboots?

I have a E6420 that I can test tomorrow.

0 Kudos
His Boy Elroy
1 Copper

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Thanks for offering Clint, I discovered that in my case the TPM was owned & I needed to clear TPM to get CCTK to work properly...

0 Kudos
Highlighted
Clint11
2 Iron

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Yeah I was going to mention that since it has been the issue before multiple times in this forum. I wish CCTK had a to check if a TPM was owned or not.

0 Kudos

Re: cctk.exe --tpmactivation=activate does not work on any of my models

SOLUTION: If you are experiencing this problem (change TPM activation state using CCTK command line, CCTK returns success, but activation state is NOT actually changed) it is most likely because CCTK cannot change the TPM activation state when the TPM is in an "owned" state.  You must first clear the TPM ownership, then CCTK --tpmactivation=activate will work properly.

This is not documented anywhere, so far as I know.  It's obviously a bug in CCTK.  CCTK should not return success when it has failed, d'oh.

0 Kudos
mohammed shafi
1 Copper

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Help is not available for the option 'tmpactivation'

0 Kudos

RE: cctk.exe --tpmactivation=activate does not work on any of my models

Hi, 

you can see help for tpmactivation as below -

Thanks

-Tarun

0 Kudos