TERIAlexK
1 Copper

Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Here is a fix for the following error message in VUM: "Invalid vendor code del in patch metadata, another vendor code with different capitalization already exists in database. Check the Update Manager log files for more details."

  1. Unzip dell-eql-mem-esx6-1.4.0.426823.zip (or similarly named file)
  2. Edit index.xml
  3. Change line 4 (ie. code tag) from "del" to "DELL" (no quotes)
  4. Zip all previously unziped files back into the originally named file.

I used the MEM 1.3 patch as a template and tested the modified MEM 1.4 on vmware 6.5.

30 Replies
Highlighted

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Hello, 

 It would be extremely helpful if anyone having this error, or any other issue with MEM v1.4 opens a support case. 

 Thank you. 

Don 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

AbeyMarquez
1 Nickel

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Yep, that's what I did on a test environment yesterday and it worked. I also was bothered by the package showing 3 separate bulletins instead of a single one. I modified the following files:

  [this fixes the inability to import the extension into Update Manager]
  index.xml : replaced the incorrect vendor code “del” with “DELL”.

  [this fixes the extension showing up as 3 different bulletins instead of 1 that encompasses all 3]
  metadata.zip > bulletins : removed the two additional files and added the two missing <vibID> elements to the <vibList> section.
  metadata.zip > vmware.xml : placed all three <vib> sections within the same main <bulletin> section and removed the other two additional <bulletin> sections.

This package imported ok, I scanned for updates and it was detected, I remediated, rebooted and it installed fine.

This is unsupported of course and I asked TechDirect if they thought it was the correct course of action but I haven't received a response yet. I'll update the thread later when they answer.

0 Kudos
AbeyMarquez
1 Nickel

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

I was just informed by TechDirect support that this is the correct fix. Also that they will be revising that version in the future.

0 Kudos

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Hello, 

 Would you please private message me the SR number for your case.  I did file a request with engineering under my name but I'd like to get the info from your case as well.  I'm hoping they gathered the VSM logs. 

 Thank you. 

Don 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Hello, 

 Do you have any other "Dell" software installed on your ESXI serves?   Or possibly did you upgrade from MEM v1.3 to 1.4?  

 We're having issues duplicating this is our labs.  Additionally, the "DELL" to "del" change came from VMware. 

 If you would like to assist with this, please either re-open your case, or open a new one.  Then ask that it be sent to Nashua.  We'll need array diags, and VMsupports from your nodes as well.  

 Thank you. 

 Regards, 

Don 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

We have the same issue :
"Invalid vendor code del in patch metadata, another vendor code with different capitalization already exists in database. Check the Update Manager log files for more details."

DEL is already being used by Dell isM and Openmanage. (and mem 1.3)
When I edit the index.xml this issue is resolved, but it wants to import 3 patches (mem 1.3 only imports 1 patch)

0 Kudos

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Hello, 

 Please open a support case.  The three entries issue is also being resolved.  But in order to track down the "vendor id" issue engineering would like to review more cases. 

 Have you tried uninstalling MEM v1.3 before installing v1.4?  

 Regards, 

Don 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
LR_Brian
1 Nickel

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Just downloaded MEM 1.4 (1/17/17) and the issue isn't fixed yet.

Installed MEM 1.4 and went to verify by executing esxcli software vib list | grep dell-eql...

dell-eql-host-connection-mgr 1.4.0-426823 Dell VMwareAccepted 2017-01-17
dell-eql-hostprofile 1.3.0-407867 Dell VMwareAccepted 2015-07-02
dell-eql-routed-psp 1.3.0-407867 Dell VMwareAccepted 2015-07-02

So I'm not certain it installed correctly.

Anyways - I'm trying to follow your instructions for fixing the metadata.zip files and I'm confused.

I have 3 files like mentioned in the bulletins folder - what would I remove (the files ending in .0 and .0.0 )?

What are the two missing vibID elements I am adding and to which file am I adding them?

Also, can you please confirm the modifications to vmware.xml?  It seems I just cut and paste the <vib> sections and move them under the first </vib>?

Thanks in advance!

0 Kudos

RE: Dell Equallogic MEM 1.4 VUM Error "invalid vendor code"

Same here, I was not able to fix the package following the instructions.
I opened up a case with DELL (#<ADMIN NOTE: request number removed per privacy policy>) but this didn't take me any step further. Recommended to install the vib with cli. At the moment I could not spend more time with that, I think I'll wait for next release, but very disappointed about the quality of that.

Best regards,

Alex

0 Kudos