Highlighted
2 Bronze

Disabling legacy protocols

Jump to solution

I'm trying to disable the legacy protocols for our Equallogic SAN.

In an putty session, I log and type the following: grpparams crypto-legacy-protocols disable

Result: Error: Bad command.

I must have the entry wrong.

I found this link which references a CLI reference guide, but can't find it anywhere online.

http://psonlinehelp.equallogic.com/en/V6.0/Content/tlskr/concepts/Administration_access_Options.htm

Any help is appreciated.

Thanks.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello, 

  You can also do it in two steps to make sure you are at correct menu level. 

GrpName>grpparams  <CR> 

GrpName(grpparams)>

Now just do the legacy cyrpto disable command without the grpparams at the beginning. 

 Regards,

Don

 

 

View solution in original post

7 Replies
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello, 

 That is the correct command 

GrpName>grpparams crypto-legacy-protocols  ? 
disable - Disables the use of legacy encryption and authentication
protocols.
enable - Enables the use of legacy encryption and authentication
protocols.

However I suspect your firmware is too old to have that feature.  What version are you running? 

 

Regards,

Don

 

0 Kudos
Highlighted
2 Bronze

Re: Disabling legacy protocols

Jump to solution

Storage update manager shows current PS series array @ v10.0.2 (R465844)

Should I be looking somewhere else?

0 Kudos
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello, 

 Just to check at the GrpName>  prompt type   show members 

 FYI: 10.0.3 is most current but 10.0.2 has the disable crypto option 

 You did this on the active controller at the GrpName> prompt at the root level?  

  Don 

 

0 Kudos
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello, 

  You can also do it in two steps to make sure you are at correct menu level. 

GrpName>grpparams  <CR> 

GrpName(grpparams)>

Now just do the legacy cyrpto disable command without the grpparams at the beginning. 

 Regards,

Don

 

 

View solution in original post

Highlighted
2 Bronze

Re: Disabling legacy protocols

Jump to solution

Looks like that worked. Thank you kindly.

0 Kudos
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello,

 That's great you are so very welcome.    I am glad that worked for you. 

  Take care. 

Don 

0 Kudos
Highlighted
4 Tellurium

Re: Disabling legacy protocols

Jump to solution

Hello, 

BTW, I have the complete answer.    When you enable or disable that command there are background processes started.  If you run the command again right away while they are running you will get that error.  Even though the command returns back to the CLI almost immediately the processes have to finish. 

 So if you wait about 30 seconds to a minute it likely would have worked. 

 By going to grpparms submenu first you allowed the processes to complete. 

  In case you run into it again on another array. 

 Regards,

Don