ph-htpgmbh
1 Nickel

EHCM service startup problem: file not fiund

Jump to solution

Hi,

on two clustered 2008 R2 boxes the ehcm service installed with hit-kit wont start due to file

not found error. The binaries are in place, other equallogic services work properly. Any ideas?

thx,

/peter

0 Kudos
1 Solution

Accepted Solutions
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

dropped my half of my posting..

problem ist the windows MPIO feature, which needs to be installed prior to hitkit. The 4.0 installer

ignores the missing feature, 3.5 requests the installation. had to uninstall hitkit, install mpio and hitkit

again and reboot to get it running...

/peter

9 Replies
Moderator
Moderator

Re: EHCM service startup problem: file not fiund

Jump to solution

Not much information to go on here, please provide the following:

- firmware of the Array Group

- version of HIT installed

- exact error message

Do you recall if you installed the hit from the console or via terminal server (remote desktop)?

joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

- FW is 5.1.2 on PS4100

- HIT kit is 3.5.5000 latest available

- error message is (translated from german server)

Services:

The service „Equallogic Host Connection Managment Service“ on „server“ could not be startet.

Error 2: The system cannot find the file specified.

0 Kudos
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

...used rdp-connection for setup

Moderator
Moderator

Re: EHCM service startup problem: file not fiund

Jump to solution

Sounds like the install did not complete properly.  I will need you uninstall and reinstall, and ensure you have “install mode” enable first (specific to RDP remote installs).

Steps

1. RDP into the host, (login as a user with administrator rights).

2. Select the command prompt icon, and right click “run as administrator”

3. Once the command screen is open, type:

change user /install

(this will enable user install mode)

4. Unistall/remove the HIT kit

5. Once removed, install the HIT kit (if you restart the Host before the install, you may need to re-enable install mode again, just repeat steps 1, 2 and 3)

6. To disable install mode at the elevated command prompt (i.e., run as administrator) type:

change user /execute

The reason for install mode is that by default Terminal Server is in Execution mode, and some drivers will not load correctly (no warning is displayed either).

- joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

Did that extactly you suggested- no success, same error. In MSi-insaller log there is an error

about mussing iSCSI- reg keys.

/peter

0 Kudos

Re: EHCM service startup problem: file not fiund

Jump to solution

Same problem here.

0 Kudos
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

good luck

/peter

0 Kudos
ph-htpgmbh
1 Nickel

Re: EHCM service startup problem: file not fiund

Jump to solution

dropped my half of my posting..

problem ist the windows MPIO feature, which needs to be installed prior to hitkit. The 4.0 installer

ignores the missing feature, 3.5 requests the installation. had to uninstall hitkit, install mpio and hitkit

again and reboot to get it running...

/peter

Re: EHCM service startup problem: file not fiund

Jump to solution

worked. THX

0 Kudos