Highlighted
babaracus
Bronze

Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

Hi,

While trying to upgrading the hit kit on windows server 2008 r2 sp1 cluster nodes from 4.6 to 4.7 I get the following error:

 “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start.  Verify that you have sufficient privileges to start system services.” 

I am logged in with a domain account with local admin privileges, I am able to stop/start all other services, I read somewhere on the net that .net framework needs to be installed... Is this correct? I don't see it as pre-req on the documentation.

now I also tried rolling back to 4.6 and still have the same problem, i logged a support call but the pro support tech could not help as he had never seen the issue nor was there anything iN his knowledge base.

Any ideas? 

Thanks,

 

0 Kudos
7 Replies

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

Try logging in with LOCAL admin account, not AD domain.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
babaracus
Bronze

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

Thanks but I already tried that and it still doesn't work!!!

Any other ideas?

0 Kudos

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

I meant to say login as Administrator not a local equivelent admin account.

I'm checking with some other folks as well.  

Is the case still open?   It can be escalated up and they can review the Windows logs for some clues.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

I believe I have found the issue.

Source: MsiInstaller Type: Error Product: Dell EqualLogic Host Integration Tools -- Error 1920.Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.

EqlASMAgent had other dependencies services that won’t also start

Upon further troubleshooting and manually trying to start the logging daemon it failed to start with a dll error

A google search with the same error produced the following.

pcsupport.about.com/.../atl110-dll-not-found-missing-error.htm

Download the Visual C++ Redistributable for Visual Studio 2012 Update 4 package and run it. This will replace/restore the atl110.dll with the most recent copy provided by Microsoft.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

babaracus
Bronze

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

Hi Don,

I will give this a try and report back, I already tried with the local administrator account but same issue... in the end I managed to roll back to version 4.6 after a reboot.

0 Kudos
RBShawn
Copper

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (EqlASMAgent) failed to start. Verify that you have sufficient privileges to start system services.” I

Jump to solution

This did get me past that error, now i have another two errors.  I hit OK and the install finishes, so I guess these maybe just related to PowerShell integration, I hope.

Error 1904.Module C:\Windows\SysWOW64\WindowsPowerShell\v1.0\Modules\EqualLogic\EqlPSArrayConfig.dll failed to register. HRESULT -2147220473

Error 1904.Module C:\Windows\SysWOW64\WindowsPowerShell\v1.0\Modules\EqualLogic\EqlPsaMgmtAPI.dll failed to register. HRESULT -2147220473

0 Kudos
A.W
Silver

RE: Equallogic HIT kit upgrade error “Error 1920. Service EqualLogic Auto-Snapshot Manager Agent (E

Jump to solution
yes, the same errors happened to me. so How did you finally fix these 2 errors? B.R Alex
0 Kudos