Highlighted
MCDI
2 Iron

Firmware for Controllers on EQL5500 are Different

We upgraded our EQL5500 from 6.0.8 to 7.0.2.  After the upgrade the secondary controller did NOT complete and is still on 6.0.8.  I attempted to "Reinstall" the firmware, but it returns an error that the controllers are on different firmwares.

How can I upgrade the secondary controller to 7.0.2?

0 Kudos
7 Replies
Dev Mgr
6 Gallium

RE: Firmware for Controllers on EQL5500 are Different

Is the active or standby controller on 7.0.2?

Usually if the standby is on the lower version, you can initiate an "update" at the command line (SSH or serial) and the standby will be pulled up to match the version on the active controller.

Member since 2003

0 Kudos
MCDI
2 Iron

RE: Firmware for Controllers on EQL5500 are Different

The standby is still on 6.0.8.  Should I just FTP the 7.0.2 back to the EQL and then SSH into and run the update.  Do I have to specify the standby (controller 1)?

0 Kudos
MCDI
2 Iron

RE: Firmware for Controllers on EQL5500 are Different

I was able to fix it with help from TS. I needed to SSH into the system and run the "Restart" command against the array.  After it rebooted the controller came back up with 7.0.2 running.

Dev Mgr
6 Gallium

RE: Firmware for Controllers on EQL5500 are Different

Do check that the other controller also ends up updating to 7.0.2. I've seen where the active ended up being the newer version, but for some reason the other controller never finished the firmware update.

Member since 2003

0 Kudos

RE: Firmware for Controllers on EQL5500 are Different

FYI:  7.0.3 is available on the support website.   Some customers reported   CMs failovers after upgrading to 7.0.x.  7.0.3 has a fix for that.

 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
LarrySolutions
1 Copper

RE: Firmware for Controllers on EQL5500 are Different

I have this exact problem on a PS4110 at the moment. Tried updating from the GUI from 6.0.6 to 7.1.9 and it successfully update one of the controllers to 7.1.9, but left the other on 6.0.6.

The current state is that the ACTIVE controller is on the LOWER version (6.0.6) and the standby is on the higher 7.1.9 version.

I cannot update via the GUI as it whinges about different versions. Restarts from GUI also fail.

Going to CLI, if issue UPDATE it all basically looks like it's going to work, but then fails to synchronize the secondary controller at the very end (times out after 15 mins).

If issue RESTART I get the option of updating the firmware (fails as above), or not applying the firmware and doing a restart. The later goes straight to synchronizing the secondary and fails (times out after 15 mins).

At this point I'm stuck. Any ideas?

0 Kudos

RE: Firmware for Controllers on EQL5500 are Different

Hello, 

 If you have support, best option is open a support case.  If not, then you can try removing the PASSIVE controller, wait one minute then re-insert it.   Then at the CLI, run update again.   See if it completes the update (downgrade process in this case) properly.   If that fails you could shutdown the array, pull the active controller out. Remove the compact flash card and use utility like "dd",  "WInImage", "WinDD" to create an image of that CF.   Then use that image to overwrite the CF card on the passive.  That would put it back to 6.0.6.  

 Do you know the exact version of 6.0.6 you have and are you using VMware ESXi?   On EQL FW versions less than 6.0.6-H2 there is a change of VMFS Datastore corruption under certain conditions. 

 If you have configured your ESXi servers to best practices this can help mitigate the issue but upgrading firmware is critical.

 http://en.community.dell.com/techcenter/extras/m/white_papers/20434601/download

 Regards. 

Don 

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro