Unable to update Firmware on replacement Controller Module

Hey all
- Dell Equallogic PS6100 unit.
- 1 of 2 Controller module's had a dead battery and we replaced it purchasing one from Dell.
- Took the old one out and confirmed the Secondary Controller is active and running connections.

- Put the replacement controller in and can see it in the GUI successfully.
- Bunch of warnings/errors in the GUI, some still active: Control Module Cache is syncing (24 hours).

- The new replacement card has Firmware 5.1.2 on it. Whenever I try to update the firmware I get this error 'Inter-controller communications failure - 99'. I have tried through CLI and GUI and tried many FW versions, as its 5.1.2 I tried firmware 5.2.9 (even though 9.0.3 is the latest) and still got the error.

- I can't find a way to update firmware on just 1 of the Controller Modules. The other healthy active Module is running 9.0.3. I'm just trying to update the firmware on my new replacement controller but can't get it working! Help please Smiley Happy Thanks 


0 Kudos
2 Replies

RE: Unable to update Firmware on replacement Controller Module

When you replace a EQL CM you swap your old SD/Flash card which holds the right FW into the new CM. Otherwise you have unmatched FWs in the EQL.


RE: Unable to update Firmware on replacement Controller Module


 As mentioned, the best option is to swap out the SD card from the original controller. 

 Depending on the specific versions, you can also go to the CLI of that member and run "update". 

 This would be WITHOUT having a firmware kit uploaded.  It will attempt to transfer the firmware from the active controller, to the passive over the controller interconnect bus.  

 If the versions are very far apart this may not work. 



Social Media and Community Professional
Get Support on Twitter - @dellcarespro