Highlighted
alex.liu
Bronze

ehcmcli -d return ERROR dm-switch kernel module is not present

Hi,

Just install the new HIT kit Version 1.2.0 into RHEL 5.x.

After complete run eqltune cmd and run ehcmcli status return error

========================================================
Summary
========================================================
  ERROR: dm-switch kernel module is not present
  Resolution: Ensure the kernel module package appropriate for your system is installed, and use 'modprobe -v dm-switch' to verify the module can be loaded.
  Adapters:         2
  Managed Volumes:  2
  iSCSI Sessions:   4
  Errors:           1
  Warnings:         10
  Suggestions:      0

run modprobe -v dm-switch
FATAL: Module dm_switch not found.

How can I install Module dm_switch manually?

dmsetup targets return
multipath        v1.0.5
raid45           v1.0.0
snapshot-origin  v1.6.0
snapshot         v1.6.0
zero             v1.0.0
mirror           v1.2.0
striped          v1.1.0
linear           v1.0.2
error            v1.0.1

Thanks in advance.

0 Kudos
8 Replies

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

What version of RHEL?  

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
alex.liu
Bronze

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

Linux  2.6.18-164.15.1.el5 #1 SMP Mon Mar 1 10:56:08 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

0 Kudos
alex.liu
Bronze

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

Will it be an issue while I get the below error in the installation process?

Error: Cannot connect to PS Series group psgroupadmin on 192.7.7.20 : Timed out connecting to group

Error: If you are using a separate management network, you will need to provide the group management IP address to ASM

Error: Group access credentials will not be stored locally

Verify the group is reachable from this host.  If you are using a separate

management network, provide the management IP when prompted.

Would you like to provide credentials for group 192.7.7.20 (Yes/No) [Yes]?

Group name [group1]:

Management IP (optional):129.127.77.77

Username [psgroupadmin]:

Password (optional):

0 Kudos

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

What version of RHEL?  5.2, 5.3, etc.  

The latest version of HIT/LE was certified against recent versions of RHEL 5.x.   For older builds you can try the older version of HIT/LE.

So you are using dedicated Mgmt on this group?   Can this RHEL server reach both IP subnets?

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
alex.liu
Bronze

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

RHEL 5.4

the package I have installed is below

dkms-2.2.0.3-1.noarch.rpm

equallogic-host-tools-1.2.0-2.iso

RHEL server can reach both IP subnets, the server have two network interface

eth0 inet addr:129.127.77.82  Bcast:129.127.77.255  Mask:255.255.240.0

eth1 inet addr:192.7.7.44  Bcast:192.7.7.255  Mask:255.255.255.0

We are using 129.127.77.82 to connect the RHEL.

0 Kudos

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

Since you don't have multiple NICs on the EQL iSCSI subnet, having MPIO isn't useful,  for performance and redundancy you should have two NICS on the iSCSI subnet.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
alex.liu
Bronze

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

Because this is the testing environment, that's why it only have 2 NICs, we have four NICs in production.

I need to test the connectivity before apply to production. Would you tell me which version of HIT which suitable for RHEL 5.4?

0 Kudos

RE: ehcmcli -d return ERROR dm-switch kernel module is not present

Hello,

That revision is too old.  Even HIT/LE v1.0.0. minimum revision is RHEL v5.5.   That kernel is too old.

If you can't upgrade, then I would suggest just using the standard MPIO and not install HIT/LE.

On the HIT/LE download page shows what versions are supported.

HIT/Linux includes tools that provide tight integration of EqualLogic PS Series arrays with Linux environments for enhanced protection, performance and simplified configuration and administration of EqualLogic PS Series storage arrays.

Version 1.2.0

Download Page Dell EqualLogic Host Integration Tools for Linux v1.2.0

Date Released November 2012

EqualLogic Product Compatibility The Compatibility Table provides a quick reference of EqualLogic product version compatibility for the last several major firmware releases

Required Linux Version Support for 32 and 64-bit Linux distributions

Red Hat Enterprise Linux (RHEL): 5.7, 5.8, 5.9, 6.2, 6.3

SUSE Linux Enterprise Server (SLES) 11 SP1 and SP2

Notes Dell EqualLogic Host Integration Tools for Linux Version 1.2.0 supports the following new features:

Support for Dell EqualLogic PS Series Firmware Version 6.0

Volume Re-thinning

Enables you to recover disk space that has become available and make more efficient use of disk capacity in storage volumes.

Soft deletions for Smart Copies in Auto-Snapshot Manager/Linux Edition

Enables you to restore a deleted Smart Copy from the volume recovery bin.

Support for 32-bit and 64-bit Linux distributions

Red Hat Enterprise Linux (RHEL): 5.7, 5.8, 5.9, 6.2, 6.3

SUSE Linux Enterprise Server (SLES) 11 SP1 and SP2

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos