Highlighted
A.W
Silver

about ASM/ME Alter settings

Jump to solution

Hello all,

I have installed ASM/ME in the windows 2008 r2 server, and enabled email alter settings. But, I find a strange thing. I have not enabled infrmational alter, such as, smart copy succeeded. as show in the follwoing photo.

But, I still can receive a mail about "HIT/ME Alter: Create Smart Copy - Success on host XXX" when the smart copy created successfully. Why?

 

Tags (3)
0 Kudos
14 Replies
Moderator
Moderator

Re: about ASM/ME Alter settings

Jump to solution

Ensure that ALL the hosts that ASM is installed on are configured for this setting.  In the middle panel select all hosts and then verify the settings.

You can also View/Change the setting on each host using the ASMCLI:

(You will need to navigate to the directory C:\Program Files\EqualLogic\bin or add the ASM/ME CLI commands folder to your path by editing your Windows PATH environment variable)

To View settings on each host:

Syntax: ASMCLI -alert -category={"category_name" | "category_abbreviation"} |

Example shows the current settings for informational Alerts:

ASMCLI -alert -category=Informational

or

ASMCLI -alert -category=I (this is the abbreviation for informational)

To change ALL the informational alerts to disabled

-disableall={"category_name" | "category_abbreviation"}

Example to disable all informational messages on the host (do this for each host)

ASMCLI –alert –disableall=Informational

This is discussed in more detail in the ASM User Guide.

If you are still having problems, you will need to open a support case.

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
A.W
Silver

Re: about ASM/ME Alter settings

Jump to solution

Thank you, Joe,

I am sure that ALL the hosts with ASM installed on are configured for this setting. - the same settings.

I also checked it with ASMCLI ...

all informational alerts are disabled.

 

0 Kudos
Moderator
Moderator

Re: about ASM/ME Alter settings

Jump to solution

what version of java is installed?

Use:

c:\java -version

c:\java -fullversion

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
A.W
Silver

Re: about ASM/ME Alter settings

Jump to solution

no java installed, ASM/ME needs Java ?

0 Kudos
Moderator
Moderator

Re: about ASM/ME Alter settings

Jump to solution

No, Java is not required; in fact the HIT v4.0 no longer installs it.  I was checking to see if you did have Java installed and what version (for conflicts, etc.).

I also did some testing on our W2K8 R2 (without SP1 installed, pretty much a basic install), and was NOT able to reproduce your problem.  If the Smart Copy Successful is checked, I receive the email, if unchecked I do not.

You can try to re-run the HIT/ASM install, but choose the “repair” option (this will require that the host is rebooted).

If the repair doesn’t fix the problem, gather the following information and open a support case:

Msinfo32, save the file as an .nfo

Systeminfo > host_systeminfo.txt (this redirects the command to a text file)

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
A.W
Silver

Re: about ASM/ME Alter settings

Jump to solution

Thanks.

I've reparied the HIT/ASM installation, but it did not repair my problem.

before opening a support case, would you like help me check the mail from EQL

I noticed there is a warining message in the mail though it is a succed mail, do you think it is the reason why I can still receive mail?

0 Kudos
Moderator
Moderator

Re: about ASM/ME Alter settings

Jump to solution

Well by the looks of this, you have a torn smart copy or missing component.  

This happens when a smart copy is scheduled but you missed a warning message that you may not have read or corrected first.  You most likely will not be able to do anything with these copies until the problem is fixed.

When creating the schedule using the Schedule Task Wizard in ASM, you would have seen a Missing Components or Volumes message and needed to correct this first.

You should also be seeing torn copy messages too.

You can delete this schedule, and recreate it to see the warning message.  Note that the Schedule Wizard will still let you save the schedule even with warnings.

So, this isn’t a message from the informational alerts, but a message telling you to correct the warning.

Any of the smart copies that were created with this schedule should be removed as well.

The ASM User Guide has more information on Torn Smart copies (with an example) that can explain how it happens and what to do to avoid it.

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

A.W
Silver

Re: about ASM/ME Alter settings

Jump to solution

Thank you, Joe

In my schedule, I create a smart copy that includes multiple database. (no missing component) I checked the user guide and found

is it the reason why I received mail?

0 Kudos
Moderator
Moderator

Re: about ASM/ME Alter settings

Jump to solution

Most likely if you have done this then yes, this would generate the warning.

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell