Highlighted
xanthus_pk
Bronze

ASF2 Force off

Hi

i am experiencing random reboots on my Dell Latitude E5440. Following has been noticed:-

1. BIOS log shows "ASF2 Fore off"

2. My Dell is also detecting unexpected shutdown.

3. My Dell Schedule Scan has passed all hardware tests.

4. At times while the laptop is plugged in, the task bar occasionally shows "battery undetected"

Need help to avoid these random reboots

0 Kudos
20 Replies
Moderator
Moderator

RE: ASF2 Force off

Hi xanthius_pk,

Thanks for the post! An ‘ASF2 Force off’ error could be the result of several problems. To try and pin this down to a single point of failure I would initially suggest running the systems preboot hardware diagnostics from the F12 menu. Full diagnostics instructions can be found here. If no issues are found in the initial scan you will be prompted to run Extended diagnostics, these tests will take around 30 minutes to complete but will thoroughly scan hardware for concerns.

 

If no errors are detected, next make sure the latest BIOS and drivers are installed on your system. These updates can all be found here. You could also install and run the Dell Command Update application linked below. This program automatically scans your system for the latest updates and installs for you.

 

Dell Command | Update

http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=H2CN6&fileId=3423072660&os...

 

You mentioned the battery is not detected intermittently while in Windows. Have you been able to test the system with the battery removed, running solely on AC, to see if the shut downs still occur? Testing the system with a known good battery would also be great, if available, to find out of the shutdowns are being caused by that intermittent detection.

 

Thanks,  

0 Kudos
xanthus_pk
Bronze

RE: ASF2 Force off

Hey Shawn

I have completed all the steps asked by you.

1. Pre boot diagnostic tests (F12) were all clear.

2. Dell Command Update was installed and all drivers and BIOS updated to the latest available version.

3. Complete Virus scan undertakken.

4. Windows updated.

No improvement still several times the system reboots and log entry is ASF2 Force off

i am attaching a screen shot from my dell system history. (Couldn't export the history).

0 Kudos
Moderator
Moderator

RE: ASF2 Force off

Hi xanthius_pk,

 

Sorry to hear that. Does the system react the same way if started in safemode? This should help pin down the issues to being caused by hardware or software. If the system is providing BSOD bluescreen error screens they can also be used to locate the cause of this issue. Check out the following Microsoft troubleshooting guide here for instructions on resolving BSOD shutdowns. http://windows.microsoft.com/en-us/windows7/resolving-stop-blue-screen-errors-in-windows-7

 

Thanks,

0 Kudos
xanthus_pk
Bronze

RE: ASF2 Force off

Hi Shawn

The problem is not BSOD, however i have already updated the windows and done a complete virus scan. Can you guide me how to export the BIOS logs or My Dell system history. The BIOS power log reads sequentially after every reboot as under:-

ASF2 force off

0 Kudos
Moderator
Moderator

RE: ASF2 Force off

Hi xanthius_pk,

 

I would suggest first testing the system in safemode. This will help rule out hardware failures, allowing the system to run with minimal start up applications and drivers.

ASF2 force off is a generic error but viewing the systems event logs should give us a clearer picture of what’s happening when the system shuts down, guide available from computerperformance - Here.

 

Thanks,

0 Kudos

RE: ASF2 Force off

Hello, I work with a large US based company that used the Dell E5430 as a standard, around 20% of our 600 of the ones we purchased had/have this issue. Its and issue with the on board video cards that Dell should really really admit too. The E5440 and smaller E6230 we have do not have this problem, but does not matter, we are no longer going with Dell as a Standard laptop because of the way they are handling this. Go to Dell support chat and describe the problem, BIOS updated to latest A15,  provide the ASF2 force off and ACPI power management errors in the Dell BIOS log and they will get the motherboard replaced, Hopefully not with an onboard video card with less RAM as has happened with some of ours.

0 Kudos
CurbedLarry
Silver

RE: ASF2 Force off

Shawn,

I can confirm this isn't a one-off and I have the same (as part of the ongoing saga with my E5440). Occurs at random when moving it, even gently, not touch battery at all.

Also have random shutdowns when docking but annoyingly they don't generate any BIOS messages.

"Battery removed" message comes first, suggesting loose battery.  Haven't tried forcing it by wiggling it.

I turned off freefall protection a couple of months ago thinking that was the cause but still happens.

Recent thread about the E5430:

http://en.community.dell.com/support-forums/laptop/f/3518/t/19615896

Old threads about the E6510:

http://en.community.dell.com/support-forums/laptop/f/3518/t/19351671

http://en.community.dell.com/support-forums/laptop/f/3518/t/19345688

EDIT: Applying a little pressure to the battery (pushing it outwards when locked) does trigger it

Doesn't look/feel loose and moves a less than a millimeter but seems to be enough to break the contacts.

Shawn, can you recreate this in the lab?

Lawrence.

0 Kudos
Moderator
Moderator

RE: ASF2 Force off

Hey Lawrence,

Thanks for the post. The ASF2 indicates a generic power loss entry to the logs, so they can be hard to pin down without thorough testing. The system i have hear doesn't have the same issue when i push on the battery, I tested with the extended life for good measure with no issue. Sounds like your system may have a bad battery or chassis latch assembly. I would suggest making sure the plastics are not cracked and the points are clean / not clogged. 

Does the system only power down for you while on dock? If so I would take a close look at the docking port its self, a bent pin or chassis issue could be causing connectivity issues?

0 Kudos
CurbedLarry
Silver

RE: ASF2 Force off

Shawn,

I had a quick look last night.  Removed battery to make sure everything was clean and no damage (shouldn't be, machine has never left the house).

After powering up I couldn't recreate the problem no matter how hard I tried!

Have a feeling it's more to do with moving/rotating the machine anyway.  On the last couple of occasions it happened when turning the machine upside down to check the fan.  Have you tried that?

When it happens the hard disc makes a noise (powering up or down, not sure) and fan spins up for a second for no reason.  Open the lid and it's rebooting.

As I mentioned I've turned off freefall protection.

Dock connector is perfect, haven't checked the one on the dock itself.  Three other guys with similar issues here:

http://en.community.dell.com/support-forums/laptop/f/3518/t/19607735

Lawrence.

0 Kudos