Highlighted

BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

Hello,

The latest BIOS 1.1.7 on the XPS 13 (9350) which does increase battery life for Windows users does not do so for Linux users due to the NVME SSD not being allowed to enter sleep modes.

At boot, many error messages coming from ACPI arise ( see http://pastebin.com/8E6iXKMM ), here are a few :

[    0.155273] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

[    0.185298] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

[    0.203571] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S1_] (20150930/hwxface-580)

[    0.203580] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State [\_S2_] (20150930/hwxface-580)

[    0.850917] acpi PNP0C0B:00: Failed to change power state to D0

[    0.870806] acpi PNP0C0B:00: Cannot transition from (unknown) to D3hot

From the looks at Arch Linux forums and reddit /r/Dell it seems like Linux users have not benefited from the last BIOS upgrade. My system also boots every other time and otherwise ends up with a black screen.

Any further BIOS updates we can expect to resolve these issues?

Many thanks! 

Tags (2)
0 Kudos
13 Replies
friimaind
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

Ubuntu 15.10 user here, same problem of beardeduncle.

XPS 9350 256GB 8GB FHD with 1.1.7 Bios in idle had an average power consumption of 5W / 7W (on idle, with tlp, i reached a 4.5W) but this is not acceptable compared to Windows.

0 Kudos
negabiggs
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

I am getting the error with Windows 10 as well, stating ASPM is disabled due to incompatibility with hardware.


Dell XPS 9350 FHD i5

BIOS 1.1.7

Samsung 950 PRO SSD 256GB

My battery life is severely impacted, and I suspect this is probably one of the issues.

0 Kudos
zetxx
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

more info about 1.1.7 buggy bios bugzilla.kernel.org/show_bug.cgi

avstehn
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

I have an XPS 13 (9343), 8GB FHD i3, and I am getting the error with Windows 10 too (ASPM is disabled due to incompatibility with hardware). I have the latest BIOS (A07).

0 Kudos
friimaind
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

@beardeduncle Just out of curiosity: what distro are you using? What kernel? Do you have some particular modules loaded on boot?

0 Kudos

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

Using Ubuntu 15.10 with i915 and nvme modules compiled into kernel 4.4 rc4.

0 Kudos

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

In the link that zetxx provided this is the latest diagnosis :

"SB_.PCI0.LPCB.H_EC.ECAV should not be defined in any dynamic SSDT tables.

So this is a BIOS bug to me."

Is there any way a Dell employee could forward this to the team developing the XPS 13 9350 BIOS?

0 Kudos
friimaind
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

Dell released BIOS 1.1.9: 

http://www.dell.com/support/home/my/en/mydhs1/Drivers/DriversDetails?driverId=376N9&fileId=350886283...

unfortunately there's no changelog, maybe it helps (now i'm going to work and I cannot test it).

0 Kudos
rjohnsondev
Copper

RE: BIOS 1.1.7 bug on XPS 13 (9350)

Jump to solution

Unfortunately the issue from https://bugzilla.kernel.org/show_bug.cgi?id=109511 still exists in 1.1.9

I believe the community would be interested in helping to fix if Dell were happy to provide the source ACPI DSL...

0 Kudos