Highlighted
magisaacs
Bronze

D600 - Can't Drive TV from S-Video Out

I have a D600 Latitude running XP. I want to view DVDs in the laptop on the TV screen. I connect a cable which is has an S-video connector and audio to connector to the laptop. The cable has 2x RCA audio and 1x composite video at the other end. I connect these into the correct sockets on the TV (or video). I can hear sound but nothing on the TV screen.

I have downloaded the latest ATI Mobility Radeon 9000 driver from the Dell site and flashed the BIOS. When I use the Advanced settings facility the only video device available is the Panel (laptop screen. There is no TV available. Also when I try and select a 2nd monitor I cab "Attach' it but not select it a as a 'Primary' (its greyed out).

Presumably the bottom line of all this is that Radeon card and/or software just isn't detecting a TV (S-video in). But why? I seem to have done everything recommended.

The only think I am unsure of is following links here onto the ATI site it appears to recommend a different driver to be downloaded as part of the Catalyst suite. Tried this but ran into issues which I didn't like the look of ("No VGA Driver present"?) so reverted back to the ATI Mobility Radeon driver.

It can't be this hard! (It isn't with my Mac)

Any advice gratefully received
0 Kudos
16 Replies
Steve911
Gold

Re: D600 - Can't Drive TV from S-Video Out

Did you make sure to have the cables attached and TV on before booting the laptop?
 
 
0 Kudos
magisaacs
Bronze

Re: D600 - Can't Drive TV from S-Video Out

Yes I have done this.

The audio is recieved but not the video. I can the odd flicker when I change a setting in Display preferences but nothing else.

Rgds

Mike
0 Kudos
djjd5000
Bronze

Re: D600 - Can't Drive TV from S-Video Out

Did you ever get this fixed? I have the same problem!
0 Kudos
magisaacs
Bronze

Re: D600 - Can't Drive TV from S-Video Out

No - and if you look at the latest message in an earlier post from'nabu' entitled "Re: latitude d600 radeon mobility 9000 tv out problems ...." it suggests that there isn't a solution to the problem becuase the Mobility Radeon card doesn't support 'Force TV Detection'.

If true this is a prety poor state of affairs to deliver a laptop with a port that doesn't work!

Mike
0 Kudos
msjsun
Copper

Re: D600 - Can't Drive TV from S-Video Out

Try press "Fn - F8" a couple of times. That is what I need for my Dell Precision M60. Good luck.
0 Kudos

Re: D600 - Can't Drive TV from S-Video Out

Hi after reading many postings, I could successfully managed to use S-Video from my Dell Latitude D600.

It originally had Mobility Radeon 9000. I 've downloaded the Omega display driver at http://www.driverheavendownloads.net/omegadrive.htm

Basically there are two things to remeber.

1. The video signals should be detected by TV automatically. If not, then we need to force the TV detection

2. Video plays only in one monitor, that is in primary monitor. So, we need to make the TV as primary monitor.

Navigate, Display->Settings -> Advanced ->Displays

Select TV as start, and select laptop monitor as stop (toggle with power-on/off icon for both these options).

There you go!

0 Kudos
magisaacs
Bronze

Re: D600 - Can't Drive TV from S-Video Out

This is encouraging but how did you work out which driver to download?

Thanks

Mike
0 Kudos

Re: D600 - Can't Drive TV from S-Video Out

The info in Omega Driver download site said, it works for every ATI driver. So, I 've selected "rad_w2kxp_omega_2675a_7z.exe" from the list. I took a risk, as I can restore anything while I am at work with my company's dektop support.
0 Kudos
magisaacs
Bronze

Re: D600 - Can't Drive TV from S-Video Out

Success!

Thanks very much for you help.

The only issue I have now is that the TV is always shown as 'not connected' and I have to switch the TV display on and 'apply' the setting.

At least I can drive the TV though!

Mike
0 Kudos